Got something else to discuss that is not covered by the previous forums? Post it here!
#63911 by Iristyle
Sat Sep 04, 2010 9:25 am
Figured that I would put this out there for the benefit of other users.

On August 30th, I was on a call at around 6PM eastern time. The call disconnected during the conversation, and I was unable to place any additional calls after that point. The ooma tone / dial tone worked fine, but after placing an outgoing call there was no ringing. Incoming calls were unaffected. The voice mail notification light would show, but pressing the button would just hang, with no audio coming out.

Interestingly, this was right around the time of the carrier issues noted here
viewtopic.php?f=10&t=26&p=77#p77

In any event, I tried cycling power on all my devices, etc. My Ooma hub lives behind my router and I have port forwards to it. The setup has worked without a hitch since I got it.


I have configured the device with a
static IP of 192.168.1.5
netmask 255.255.255.0
DNS 192.168.1.1 (DNSMasq is enabled on the router so it forwards to the ISP)
router address 192.168.1.1

built-in MAC of (redacted) for the MODEM Mac address.

My router runs dd-wrt v24-sp2. With the static IP set, I have the following port forwards setup:

UDP port 1194
UDP port 3480
UDP port 514
TCP port 443
UDP port range 49000-50000

I do not have QoS enabled within dd-wrt as it doesn't work properly from all accounts.

If I connect a laptop to the HOME port, so that I can hit setup.ooma.com -- I have the following status information:

Device Status - Rev 37120.37120
MODEM - Connected 192.168.1.5
Ooma Tunnel - Connected

Services
Telephony - 50 - Running
DNS - 45 - Running
Web Server - 47 - Running
VPN - 141 - Running
Free 38432

Under Ports

MODEM Link encap: Ethernet HWaddr (redacted)
inet addr:192.168.1.5 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3774 errors:0 dropped:0 overruns:0 frame:0
TX packets:4002 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:392204 (383.0 KiB) TX bytes:419600 (409.7 KiB)
Interrupt: 13

Anyhow -- I'd generally like to think that as a software developer / computer enthusiast, that I had the issue narrowed down to some sort of network connectivity issue.

Sent a couple emails to Ooma -- they weren't too helpful.


Finally, I changed my router config and moved Ooma into the DMZ instead... presto. I don't really keep tabs on the firmware versions that are sent to the device, so I'm guessing one was sent down that requires additional port mappings or a modified network configuration. Not sure if anyone can confirm that directly from Ooma, but I haven't had a chance to look at /perform Ethereal captures to inspect the traffic. I did notice in my dd-wrt status monitoring, that number of connections from the device went from 3 to 4-6 when I pushed it over to the DMZ.

Figured I'd put this out there for anyone else who might be struggling with the same issue. I'd love to know what happened under the hood with the network changes.


Thanks

Who is online

Users browsing this forum: sugg and 16 guests