Got something else to discuss that is not covered by the previous forums? Post it here!
#2751 by sunrisepostal
Mon Feb 09, 2009 2:10 pm
I put for my credit request about 22 days ago but i still did not see on my account i email support about three time with no respond from then call about three time keep telling me wait one hour and check your account its should be there but i still did not received yet.

can some one tell me how long its take to receive this credit.
are they relay give this credit or just want sale more unit using this promotion.

Thanks,

I did received this morning.
Thanks
Last edited by sunrisepostal on Tue Feb 10, 2009 7:57 am, edited 1 time in total.
#2784 by trigler
Tue Feb 10, 2009 6:05 am
It took about three weeks for me to receive my credit, but I did receive it and have been using it. So far, they've carried through on everything they said they would do. I trust they are an honest, ethical bunch, but do think they are a bit overwhelmed by the response they received, and just have more work than people. Give them a chance, I'm sure you will receive your credit.

Tom
#2801 by oomaholic
Tue Feb 10, 2009 5:36 pm
Tom,

Did you get the credit towards your account automatic or did you have to contact customer support?

Let us in on the secret. Thanks
#3016 by aphex
Sat Feb 14, 2009 6:58 pm
Same problem here. I applied for the $50 credit about 1.5-2 weeks ago and I still haven't been credited the money.

E-Mails to support have gone unanswered.

Who is online

Users browsing this forum: Google [Bot] and 14 guests