Got something else to discuss that is not covered by the previous forums? Post it here!
#95237 by Linus
Tue Apr 24, 2012 9:20 pm
I have my Ooma set up between my DSL gateway and my router, and prefer to keep it this way so I can turn the router off when I'm not around. I'd like to forward ports 80 and 443 to my (intermittent) web server, and I know they aren't blocked by my ISP or my router because I got it to work when the Ooma was behind the router. My Ooma is at, and even though I have both ports configured to forward to (the only IP address Ooma's DHCP is configured for), my Ooma still insists on responding on port 80, showing me the screen even when I navigate to my public IP address. I thought the whole idea of port forwarding is passing the traffic through, not blocking it or responding to it?!

I've also played around with setting the DMZ to, but it seems to have no effect. Any ideas?
#95239 by murphy
Wed Apr 25, 2012 2:17 am
Are you testing from outside of your network? Ooma doesn't do loopback so you can't test from inside your network.
#95483 by Linus
Wed May 02, 2012 5:57 pm
Any ideas on this? The Ooma always gives the router (verified on the router's status page), and I've attached a screenshot showing my port forwarding setup on the Ooma. The router always gives the server (verified via ipconfig on the server), and I've attached another screenshot showing my port forwarding setup on the router.

Other things I've done:

My Ooma is doing the PPPoE authentication; could that somehow be related to my troubles? Any other ideas of things to test our research are welcome.

OomaPortForwarding.gif (23.42 KiB) Viewed 6702 times
RouterPortForwarding.gif (20.37 KiB) Viewed 6702 times
#96908 by lbmofo
Mon Jun 11, 2012 10:26 pm
Trying to gain some understanding of what you did to your Ooma device. Does it look like this?

Home Port

DHCP Configuration
#108516 by Linus
Sun Apr 07, 2013 8:17 am
I gave up on this for a while, but I came across another situation in which I'd like port forwarding to work, and it still doesn't. I'm trying to host an internet game (from my laptop) that communicates on port 17011. The online instructions say that port is the only one that needs to be forwarded. When my friend hosted a game and tested port 17011 via, it worked. It doesn't for me.

lbmofo was correct about my configuration. The attached screenshot shows it. My router is at, and it's set up to reserve for my laptop (DHCP reservation, not a static IP). Even though I set up the Ooma to forward traffic on port 17011 to the router ( and the router to forward traffic on port 17011 to my laptop (, says the port is closed (yes, this is while I'm hosting a game). I also tried setting the Ooma to consider the router a DMZ, but that didn't work, either.

Before, when I was trying to get a server to respond to web traffic on ports 80/443, I was able to get it to work using the Modem-Router-Ooma configuration, but not my preferred Modem-Ooma-Router configuration (I want to be able to turn off the router without affecting calls). I haven't tried switching configurations since I've started messing with the game, but I'm pretty sure it would work.

I've found some other threads that sound like similar problems:

I'd really appreciate any ideas on how to get this working.

OomaIPConfig.gif (15.24 KiB) Viewed 6006 times
#108522 by Linus
Sun Apr 07, 2013 5:05 pm
Okay, so there's a term for the way I've got my network set up (double NAT). I've read several pages like this one that don't tell me anything new. I've tried putting the router in the Ooma's DMZ (fail) and I've tried forwarding ports in both devices (fail).

What I really want to know is why I can get port forwarding to work in Modem-Router-Ooma (single NAT) configuration, but not in Modem-Ooma-Router (double NAT) configuration. If there's any information I haven't provided that would be helpful in answering this, please let me know.
#108523 by murphy
Sun Apr 07, 2013 5:45 pm
How are you testing your forwarded port?
You can't do it from inside of your network.
You must use a computer that is outside of your network.

Ooma should be left at it's default IP address of
The DHCP table in the Ooma should be set to start and end with IP address

Set the Ooma to use its built-in MAC address

The forwarding rule in the Ooma should forward port 17011 to
Both UDP and TCP should be forwarded.

The DHCP table in your router should stay at it's default.
The reserved IP address in the router must be within the start and end IP address of the routers DHCP table.

Forward port 17011 (UDP & TCP) in your router to the reserved IP address.

Make sure that the conputer actually gets the reserved IP address. If it already has a different IP address you may have to make the computer and the router forget that IP address before it will get the reserved IP address. A computer always asks for the last address that it had and if it is available the router may assign it if the reservation coding was not done properly. Many routers don't do it correctly.

Who is online

Users browsing this forum: Google [Bot] and 13 guests