Problems with Telos

Got something else to discuss that is not covered by the previous forums? Post it here!
Post Reply
rooflady
Posts: 17
Joined: Wed Jun 30, 2010 10:04 am

Problems with Telos

Post by rooflady » Wed Feb 22, 2012 9:29 am

I have had Ooma for over 1 1/2 years. I have had ongoing problems with the Telos since the beginning. Working with Customer service, I thought everything was OK now. However, I still have at least one phone that is not working correctly. I'm not sure if it's the phone or the battery. I have 4 Telo phones. Phone (in my bedroom) is fully charged. I can receive a call, then the next one, the phone is completely dead. Nothing on it and doesn't ring. This has happened twice this week. Very upsetting. I'm afraid if there's an emergency, the phone won't work. I have recharged it and re-booted the Ooma box yesterday. Also seems to affect the phone in another room. Please help. I have the maintenance plan. Thank you.

thunderbird
Posts: 6388
Joined: Mon Nov 08, 2010 4:41 pm

Re: Problems with Telos

Post by thunderbird » Wed Feb 22, 2012 9:52 am


rooflady
Posts: 17
Joined: Wed Jun 30, 2010 10:04 am

Re: Problems with Telos

Post by rooflady » Thu Feb 23, 2012 5:29 am

Thank you. I am probably going back to Vonage.

User avatar
lbmofo
Posts: 9337
Joined: Sun Mar 14, 2010 7:37 pm
Location: Greater Seattle
Contact:

Re: Problems with Telos

Post by lbmofo » Thu Feb 23, 2012 6:41 am

rooflady wrote:Thank you. I am probably going back to Vonage.
Instead of drastic measures, why not consider getting a multi-handset DECT 6 phone system and plug the base into the Telo and use those for now. You may want to leave 1 Telo handset in service for instant 2nd line purposes.
Customer Since: 3/13/10
Hardware: Telo & Hub
Service: Premier 12/06/10
Verizon Port: 3/15/10 - 4/02/10
Internet: 100 Mbps/10 Mbps
Setup: SB6141/R6700/Ooma
MainStreetSHARES Ebates: get Ca$h Back when you shop online!!

Image

Post Reply