Having trouble placing or receiving calls or using your voicemail system on Ooma Telo VoIP Phones? Post your questions here.
#60603 by drinian11
Sat Jul 24, 2010 1:31 pm
Hi guys,

Just set up last night so I am very new to Ooma. I am using ooma telo and the ooma handset. I also have the premiere subscription. The first problem I am having is with the handset. When i receive a call, it stays stuck on the call screening screen with the option to answer or VM, even hours after the person has hung up. To clear it, i have to pick up the phone and select one of the options. Is that normal? It seems to be doing it even with call screening turned off. Any feedback would be much appreciated. Thanks in advance.
#60717 by ntoy
Mon Jul 26, 2010 10:40 am
Hello,

I assume you tried some troubleshooting steps already:

-Removed battery from handset about a minute & then plugging back in
-Placing handset in cradle, go to Handset Setup>HS SW Update & select to update
-Factory reset on handset:
1. Hold down red button until handset goes off(about 3 sec)
2. Press the red power button & before the display lights up, hold down the 0 key & left soft key at the same time. (left soft key is the button above the green phone key).
3. Handset will be in registration mode & can be re-registered to your Telo.

Other than that, you may want to contact our support folks & they can further assist
to see if an RMA is needed.
#61309 by ntoy
Mon Aug 02, 2010 9:50 am
Hello rusty1060,

I assumed you tried the above steps.
If you are still having difficulties, you may want to contact our support folks & may need to
RMA your handset.

Who is online

Users browsing this forum: No registered users and 6 guests