Voicemail displays my own number instead of caller's

Having trouble placing or receiving calls or using your voicemail system on Ooma Telo VoIP Phones? Post your questions here.
Post Reply
PetalumaRealtor
Posts: 26
Joined: Mon Jan 04, 2010 4:08 pm

Voicemail displays my own number instead of caller's

Post by PetalumaRealtor » Fri Jan 08, 2010 5:35 pm

My ooma is working great. Telo and 3 handsets. Premier. Intragated with landline. When I get a voice mail, my own number is displayed as the caller on the voicemail screen in my Ooma. The call logs display the correct number calling. The e-mail sent me also displays my own number instead of the callers number. Does anyone else have this problem or know how to get it fixed? :?:

User avatar
bw1
Posts: 1781
Joined: Wed Mar 18, 2009 9:06 am
Location: MI

Re: Voicemail displays my own number instead of caller's

Post by bw1 » Fri Jan 08, 2010 7:10 pm

I haven't seen that problem. I wonder if it's because of your integrated landline.

PetalumaRealtor
Posts: 26
Joined: Mon Jan 04, 2010 4:08 pm

Re: Voicemail displays my own number instead of caller's

Post by PetalumaRealtor » Mon Jan 11, 2010 5:57 pm

I am still having the problem. I tried a full reset of the system and that did not fix it. I can not believe that I am the only Ooma user having the this problem. :?:

cclauset
Posts: 13
Joined: Wed Dec 02, 2009 7:44 pm

Re: Voicemail displays my own number instead of caller's

Post by cclauset » Tue Jan 12, 2010 7:34 am

I had the same issue before I ported my landline number to Ooma (and disconnected the landline).

ntoy

Re: Voicemail displays my own number instead of caller's

Post by ntoy » Tue Jan 12, 2010 4:40 pm

Hello,

This has been reported as bug 7054.

skisnow
Posts: 6
Joined: Wed Jan 13, 2010 2:55 pm

Re: Voicemail displays my own number instead of caller's

Post by skisnow » Thu Jan 14, 2010 2:24 pm

I'm having the same issue on my Telo. After I left a test message on my voicemail, I listened to it from ooma.com. I deleted that message, went into the trash folder to see if it was there, and listened to it again. The message that played, however, was not the one I just deleted, but rather the Welcome to Ooma voicemail that I still have in my inbox. Something is cleary is getting mixed up.

mkazemba
Posts: 1
Joined: Tue Dec 29, 2009 1:45 pm

Re: Voicemail displays my own number instead of caller's

Post by mkazemba » Wed Jan 20, 2010 4:57 pm

Having same problem. Email notification and Ooma Inbox on My Ooma shows that the call received was my home number. Also, caller ID does not always work and we've had some problems with call waiting (can't flash to waiting caller). I am integrated with my landline due to the need to keep my home security system working. Ooma -- please fix ASAP. This is a great service if these bugs can get worked out.

User avatar
bw1
Posts: 1781
Joined: Wed Mar 18, 2009 9:06 am
Location: MI

Re: Voicemail displays my own number instead of caller's

Post by bw1 » Wed Jan 20, 2010 7:32 pm

Since you have an integrated landline:

viewtopic.php?f=2&t=194&p=685#p685
Dennis P wrote:ooma is only able to provide caller-id information for calls received on ooma phone numbers. We are unable to provide caller-id information on calls received on a landline (you must subscribe to caller-id from your phone company in that case). If you were to cancel your landline and pick an ooma phone number or port your landline number to ooma, caller-id would then be provided.
Call waiting on your landline won't work on your Ooma.
You must contact Ooma customer support and have your landline provisioned to add call forward busy to your landline. This is an additional monthly charge and allows you to accept a second call when the landline is in use. They also remove voicemail, call waiting and call forwarding. See here:

http://cp-ooma.talismaonline.com/articl ... 19&p=12040

Here's a better option:
Most of us here recommend not integrating your landline, whether your just testing the Ooma service and will eventually port your number or even if you want to keep your landline for a backup service. The reason is that all incoming calls and local outgoing and 911 calls will be through your landline service. Only long distance calls will be through the Ooma service. Also, you give up much of the included functionality like caller id and call waiting from Ooma.

brzf400
Posts: 1
Joined: Fri Jan 22, 2010 8:40 pm

Re: Voicemail displays my own number instead of caller's

Post by brzf400 » Fri Jan 22, 2010 8:56 pm

I have same problem of Voice Mail issue with my new Ooma Telo which I activated on Jan 16, 2010.
I also have Call Waiting issue because Ooma Telo does not pick up another incoming line when I am on the phone. I currently still have a land line and have requested to port my existing phone number, which I am told will take few weeks. Should I wait till my existing phone number is ported to Ooma and then I can de-activate my land line. I am not sure after porting the number and de-activating land line, my current problems with Voice mail displaying my own number instead of caller's and Call waiting Issues with also caller ID problems will be resolved??
i have called Ooma customer service, but problems not resolved yet.

murphy
Posts: 7261
Joined: Tue Jan 27, 2009 12:49 pm
Location: Pennsylvania

Re: Voicemail displays my own number instead of caller's

Post by murphy » Sat Jan 23, 2010 3:59 am

Do not cancel your land line before the port completes or you will lose your phone number. Completion of the port should automatically cancel the land line.
Customer since January 2009
Telo with 2 Handsets, a Linx, and a Safety Phone
Telo2 with 2 Handsets and a Linx

Post Reply