Having trouble placing or receiving calls or using your voicemail system on Ooma Telo VoIP Phones? Post your questions here.
#80308 by cdamania1
Tue Apr 26, 2011 2:31 pm
Hi All,

Not sure if anyone else is experiencing this. This started yesterday around 5PM set time. My caller ID does not display names anymore. It only displays the phone number on both lines. Before for all calls it would display the name and the number. Not sure what is going on.

When i go to the setup.ooma.com i see that the advance caller ID is inactive. Not sure what is going on. I had this working before on my ooma basic service and it was working on my ooma trial as well.

Anyone else experiencing this issue..
#80311 by tomcat
Tue Apr 26, 2011 2:42 pm
CallerID names are only available with Premier service. If you only have Basic then you only get numbers for your CallerID. I'm guessing your trial to ooma premier has expired.
#80313 by cdamania1
Tue Apr 26, 2011 3:00 pm
tomcat wrote:CallerID names are only available with Premier service. If you only have Basic then you only get numbers for your CallerID. I'm guessing your trial to ooma premier has expired.


Do you know when this went in effect.. I been a ooma customer for a long time and i know for a fact that i was on basic this whole time and i was getting names.

Just recently 2 months a go my device died and had to get a new device and rather than moving my entire account i just moved my number over and i had the 2 month trial for premier. then all of a sudden it stopped.
#80315 by tomcat
Tue Apr 26, 2011 3:10 pm
Were you a core user with your previous device? It sounds to me that even though you moved your number over, your account is considered a new account and subject to the two month premier trial (as you mentioned). I am under the impression that CallerID name has always been part of the premier service for the telos and not part of the basic.

I feel as though I have quickly gotten in over my head on this question. Hopefully someone else with more experience on this subject will step in.
#80317 by southsound
Tue Apr 26, 2011 3:48 pm
I checked and found the same thing on my caller ID on an intermittent basis. Some names come through - others are just the numbers. Landlines should always have the name but even these are affected. My service level is Premier so I think it is a bug. I normally don't care about the caller ID because we use naked GV as a front end and use call presentation so the GV system speaks the caller's name to us.
#80321 by lbmofo
Tue Apr 26, 2011 6:13 pm
cdamania1, with base/free service, only the Core is supposed to have callerid with name. If you originally activated any other hardware, your base service would only get callerid number.

Ooma Hub vs. Ooma Telo: viewtopic.php?t=9245#p64442

viewtopic.php?f=6&t=9092&start=10#p64588
Bobby B wrote:We haven't got around to disabling caller-ID name for all Telo Basic users. This will likely be phased in sometime this year.

The main reason we didn't disable the caller-ID name for Telo Basic users during the initial Telo launch was because the contact list feature wasn't ready. We decided to absorb the cost of caller-ID name lookups until then.

viewtopic.php?f=6&t=9092&start=10#p64591
Bobby B wrote:There are no plans to disable caller-ID name lookups for Hub Basic users until we get address book lookups working on the Hub.

Who is online

Users browsing this forum: No registered users and 9 guests