This forum includes tips for maintaining the best audio quality possible with the Ooma System. If your Ooma system is having issues with dropped calls, static audio or echo, look here for assistance.
#58116 by Albert
Thu Jun 17, 2010 1:31 am
My setup is DSL Modem -> Router -> Ooma, where the router is just
the default setting without any QoS tuning. Since day one, I had
no issues with voice quality or set-up problems for the first 6
months. (I like this Modem -> Router -> Ooma set-up since the DSL
provider provides static IP and this is easier for my internal
network connections.) The voice quality was excellent and I was very
happy with it.

However, in the recent month, I continued to have voice-quality
problems with the out-going voice --- the other end often heard
dropping/quivering voice of my talking. It was so bad that the
other end could not understand what I said.

My router is LinkSys BEFSR41 version 4.2 bought about 3.5 years
ago. My subscribed DSL speeds are

1 Mbs download & 384 Kbs upload.

When I did speed tests (on speedtest.net and
speakeasy.net/speedtest), it was

about 1.04 Mbs download and 190 Kbs (or even lower) upload

when the testing computer was behind the router. When the testing
computer was connected directly to the DSL modem (i.e.,
by-passing the router, no ooma involved), the speeds were

about 1.04 Mbs download and about 380 Kbs upload.

So it's not a problem of the DSL provider. Now I changed the
router (still between Modem and Ooma) setting as follows:

Security:
Block Anonymous Internet Requests: --> Disabled

QoS:
Enable QoS
Upstream bandwidth: Auto

Device Priority: "High" priority for Ooma (specified by its MAC
Address --- this MAC Address appeared in the DHCP table so it's
correct)

All other ethernet ports and applications are the default "Low"
priority, where for each of the 4 ports, the "Flow Control"
is "Enabled" and "Incoming Rate Limit" is "Disabled".

With this setting, the speed test (with the testing computer
behind the router) results were much better (upload speed
typically 370-380 Kbs, but still sometimes 190 Kbs). The voice
quality seemed to improve, but similar problem still occurred
from time to time.

Question:
What is the right setting to set up the router QoS? (I once
set "Upstream bandwidth" to "Manual" and gave the value "380 Kbs"
or "300 Kbs" but the upload speed results were quite bad (130-190
Kbs) and the voice quality was horrible.)

I know that this might be a router problem and I am considering
buying a new router. But before doing so I would like to know the
right QoS setting on the router and give it a try. Please
help. Thanks a lot and all the best.
#58117 by murphy
Thu Jun 17, 2010 2:14 am
The way to see if the router is the problem is to connect the ooma box directly to the modem and leave the router out of the picture.
#58188 by Albert
Thu Jun 17, 2010 7:37 pm
Thanks. I have put the ooma box between the modem and the router. Will let you know how the voice quality goes after testing for a few days.
#58683 by Albert
Sun Jun 27, 2010 12:29 pm
OK, this is to follow up. After changing my setting to
Modem --> OOMA box --> Router,

the problem went away and the voice quality became excellent again. So I believe that the original problem was because of the router. However, with this new setting the computers connected behind the router also get nice Internet performance and thus I am still keeping the router. Thank you murphy for the suggestion.

BTW., in the OOMA box, I set it up (by going to http://setup.ooma.com/) with "Use Built in Modem Port MAC Address" instead of "Automatic". Also, I used a static IP for OOMA as it is required by my DSL provider for anything that's connected directly to Modem. It's interesting to know that in OOMA static IP setting, the "default gateway" IP should be entered in the field called "Router Address" in OOMA, which is a bit confusing. Just my two cents. :)
#59199 by Gearscout
Sat Jul 03, 2010 4:13 pm
I'm very new to Ooma, 1 day.

I am a Comcast Cable user in Atlanta and regularly test at 20 Mbit down and 4+ Mbit upload speed. That's on the local Atlanta Speakeasy server test, so it's a bit inflated.

I didn't want to hang the rest of my system off the Ooma router, for more than 1 reason. So I am letting it have one of the direct plugs off the back of my Linksys WRT54G router. The router has QOS settings and I used the MAC address to designate treatment of the Ooma box as a "High" (not "Highest") priority. I also engaged the option to make port #4 (the router port where the Ooma box is connected) set to "High."

It's working very well.

One of the reasons I didn't want the Ooma Telo out in front of the router is the very real possibility I'm going to have to move it to the middle floor in my house. Initial tests with the Telo Handset make it clear enough it can't reach from my basement to my third floor. This way, I can just make a short ethernet run from my basement office to the kitchen upstairs...we're remodeling and there are holes in my ceiling already!

When you set up behind the router, you can't see "setup.ooma.com/" -- but if your computer is hardwired to ethernet, just plug the ethernet cable into the "Home Network" plug in the rear of the Telo. Wait a few seconds and it should get a connection there and enable you to get inside the Telo unit. I disabled all of its QOS features.

Thanks everyone for the tips in this thread.
#59227 by cukev
Sun Jul 04, 2010 11:11 am
Gearscout wrote:
When you set up behind the router, you can't see "setup.ooma.com/" -- but if your computer is hardwired to ethernet, just plug the ethernet cable into the "Home Network" plug in the rear of the Telo. Wait a few seconds and it should get a connection there and enable you to get inside the Telo unit. I disabled all of its QOS features.

Thanks everyone for the tips in this thread.


It should be able to access "setup.ooma.com" from router if you have a TCP port 80 forward rule setup on ooma device.

- Plug one end of the ethernet cable into the "Home Network" port in the rear of the Telo
- Temporary change your PC to static IP and assign any IP address in the range 172.27.35.2 - 172.27.35.254, i.e. 172.27.35.100. Gateway IP address points to the Telo 172.27.35.1
- Plug other end of the ethernet cable to your PC (now your PC and the Telo are in the same subnet 172.27.35.x)
- Open you Web Browser and access to the Telo, http://172.27.35.1 and you should see the ooma setup page
- From "Navigation" window, go to ADVANCED, make sure there is nothing in DMZ, then add a new port forwarding TCP rule for port 80 and forward it to 172.27.35.1, click UPDATE
- Remove the ethernet cable from the "Home Network" port in the rear of the Telo
- Restore your PC back to original IP address setting
- Plug your PC back to the Router
- Open you Web Browser and access to the Telo via the IP address that you assigned static or your router assigned via DHCP (it should be in the router IP range, ie 192.168.1.x). You should be able to see the ooma setup page.

Hope it helps.
-Kevin

Who is online

Users browsing this forum: No registered users and 10 guests