This forum includes tips for maintaining the best audio quality possible with the Ooma System. If your Ooma system is having issues with dropped calls, static audio or echo, look here for assistance.
#93398 by EX Bell
Sun Feb 26, 2012 10:43 pm
Just wanted to update what I've done to resolve the missing QoS capability in Time Capsule. As I said before, I didn't want to move the Telo between the modem and router. It doesn't have any way to reserve IP addresses and that's a no-go for me.

I had an old Cisco Linksys WRT160Nv3 that I was not using, so I thought I would use it to manage QoS on the network since it has that capability. I tried to use it with DD-WRT firmware, but it didn't connect to my ISP via PPPoE as required, so I reverted it back to the latest Cisco firmware and it has worked out perfectly so far. Without the WRT160N in between, the upload speed and sound quality were taking a direct hit when my network was very busy. With it in place the calls remain crisp and steady.

I first setup the ISP connection to PPoE and then setup the router IP to be the same as my Time Capsule was. Next I configured the DHCP server settings exactly as they were on Time Capsule and reserved the same IP addresses as I had before. Next I put the Telo into the DMZ, setting the source IP address to use "Any Incoming IP Address" and the destination to be the MAC address of the Telo Internet port. I enable QoS and using the "Voice Device" category, I set the MAC address of the Telo Internet port to use High Priority. I found that, as suggested, it was necessary to change the QoS setting from Auto to Manual at 80% of my upload speed, which is 520 kb/s on average with my service. When I left the setting at Auto, it did not work properly and it was as if I had QoS disabled.

I disabled Wireless WMM support found in the QoS tab, as I had also disabled the wireless antenna on the router. I will continue to use the wireless on my Time Capsule so Time Machine backups function correctly. I found that it was necessary to repoint to the Time Capsule backup drive in the Time Machine settings, because a network error occurs when Time Machine first tries to backup under the new configuration. It then has to create a new backup for Time Machine, which is large and takes too long to do the initial backup over WiFi, so a single overnight backup over Gigabit ethernet will resolve that issue. Not a big deal. I tested this very thoroughly and with QoS enabled, while I have lost 20% of my upload speed, the Telo performs perfectly, even when the network is taxed hard by other activity, as it should.

The Time Capsule "Internet Connection" under the Internet tab gets set to Connect using: Ethernet and the "Connection Sharing" is set to Off (Bridge Mode). TCP/IP settings will switch to Configure IPv4: Manually. This and the IP addresses that show up in this tab can be ignored.

My ethernet connections are as follows:
DSL modem>Linksys WRT160N>Time Capsule>Ooma Telo

The modem is connected to the WAN port of the Cisco WRT160N, one port of the built in switch on the WRT160N goes into the WAN (Internet) port of the Time Capsule and the built in switch on the Time Capsule has the Telo plugged into one port, my print server into the second and the third is my Cisco E2000 which is a VPN server for my HTPCs.

Everything seems to be working fine, no difference other than I now have QoS.
#93404 by rpiotro
Mon Feb 27, 2012 7:11 am
You could put your Time capsule in bridged mode and just use the Telo as a router. See my post here.

viewtopic.php?f=9&t=13420
#93407 by EX Bell
Mon Feb 27, 2012 8:00 am
Go with what works. If the Telo before the router with the router in bridge mode works, then that's what you should use. However if it's not working for you and it works better to put the Telo after the router, then do that. If the Telo is directly connected to your modem and doesn't work well when nothing is connected to it's home port, then putting it behind a router isn't going to improve things.

The Telo has very basic routing capabilities, and it doesn't meet everyone's needs. To make matters more complicated for some people, they have modem/routers which require a bit of experience to configure if you don't want to add another router to the mix. I know that here, both Bell Canada and Rogers Cable are supplying these combo devices. I have no hands on experience with the Rogers modem/router, but the Bell 2Wire DSL modem/router is junk and I've encountered high end HP Ethernet enabled printers that will not work with it. When I configured a Cisco router behind it, everything worked perfectly and network performance improved.

Who is online

Users browsing this forum: No registered users and 3 guests