This forum includes tips for maintaining the best audio quality possible with the Ooma System. If your Ooma system is having issues with dropped calls, static audio or echo, look here for assistance.
#69858 by reem01
Mon Nov 29, 2010 7:39 pm
cpcosmo glad they fixed your connection, too bad that didn't help your delay. I am not trying to hijack your thread, seems like we are having very similar issues. Hopefully this will get fixed for the both of us.

lbmofo I measured 16 points over a 50 second call. I average about 865ms delay. Appreciate the assistance.
#69925 by wristwatch
Wed Dec 01, 2010 7:44 am
Here is the documentation I created for myself for future Ooma Telo installations that I may be responsible for setting up and is based on the steps I took to establish my current setup. I am running Tomato on a Linksys router. My QoS settings provide an excessive amount of bandwidth for Ooma Telo use. Before establishing QoS on the Linksys router some of my words were getting clipped on outbound calls but setting up the QoS on the Linksys and disabling QoS on the Ooma Telo unit itself has corrected the issue.

Note: I initially had made an error of setting up QoS based on the MAC address specified on the sticker of the Ooma unit or included Ooma doc. That MAC address was for the Home NIC and not the Internet NIC.

Network Setup: Cable Modem -> Linksys Router (Tomato) -> Ooma Telo

ooma telo setup instructions

Initial Network Setup: Cable Modem -> Ooma Telo -> PC
activate ooma telo
connect ooma to pc
reboot pc
go to: http://setup.ooma.com
set ooma telo's QoS to '0' to disable it
set ooma to a static IP address outside of the DHCP IP pool if static IP is allowed
(ping first to verify unallocated IP Address)
important: lookup and write down the MAC Address for the Internet NIC port of Ooma Telo in the http://setup.ooma.com
if it is not listed then acquire the MAC address from the linksys router 'device list' setup web page
NOTE: MAC address sticker on Ooma Telo and in document is for the *Home Network* NIC (don't need that address)
power down ooma telo
power down pc
connect ooma telo to router (modem->router->telo)
power up ooma telo
wait up to 30 minutes for all of the ooma lights to turn blue and *remain solid* blue
connect to linksys router setup page
setup QoS on the linksys router by using the MAC address of Ooma Telo's *Internet* NIC MAC address
- click QoS
- click Enable QoS
- Default Class: Low
- Outbound Max Bandwidth: 3000 (NOTE: This is 3000 kbps for My Comcast Upstream Speed 3Mbs)
- Highest 70% 100% (900 Kbps reserved for ooma upstream)
- High 10% 100%
- Medium 5% 100%
- Low 3% 100%
- Lowest 2% 95%

Inbound Max Bandwidth: 19000 (NOTE: This is 19000 kbps for My Comcast Downstream Speed 19Mbps)
Highest: 100% (Essentially give highest priority and 100% of available downstream to Ooma Telo device)
High: None
Medium: None
Low: None


Click "Classification" under "QoS"
From: <Set Ooma Telo MAC Address of its *Internet* NIC port goes here>
Class: Highest
Description: ooma
TCP/UDP
Any Port

FROM: Any Address
Class: High
Dst Port: 80,443
Description: WWW
TCP

From: Any Address
Class: Low
Dst Port: 80,443
Description: WWW (512K+)
TCP

TCP/UDP
Dst Port: 53
Class: Lowest
Description: DNS (2K+)

TCP/UDP
Dst Port: 53
Class: High
Description: DNS

TCP/UDP
Dst Port: 1024-65535
Class: Lowest
Description: Bulk Traffic
Last edited by wristwatch on Fri Dec 03, 2010 9:14 am, edited 1 time in total.
#70120 by reem01
Sat Dec 04, 2010 9:41 am
cpcosmo, I will be interested to see if this helps your delay, please respond either way.

wristwatch did you have a delay as well? I have not had any issues other than the delay, so hesitant to do this, but may anyway.
#70128 by wristwatch
Sat Dec 04, 2010 12:47 pm
reem01 wrote:wristwatch did you have a delay as well? I have not had any issues other than the delay, so hesitant to do this, but may anyway.


Yes, I had a delay / latency with the Ooma Premiere phone service. I have since been tweaking my QoS settings some more. Ooma asked me to change my setup to modem->telo->router for 24 hours and set QoS in the telo. I did that but my delay / latency has NOT improved.

I read some more about QoS and the WRT54GL router. Apparently the WRT54GL begins to get sluggish with high speed cable connections (16Mbps+ Downstream) due to the limited amount of memory and 200 Mhz processor. It was suggested that the Asus RT-N16 would be a good replacement router. I am sticking with my WRT54GL for now. My downstream has been around 19 Mbps - 20 Mbps and averaging around 3 Mbps upstream.

I changed my setup back to modem->router->telo, disabled the QoS in the telo, and changed and simplified my QoS settings in Tomato. My QoS settings are temporary at this point but here is what I have:

QoS Basic Settings Screen

x Enable QoS
_ ACK X SYN X FIN X RST
X Prioritize ICMP
X Reset when changing settings
Default Class: Low
Outbound
Max Bandwidth: 1956 (70% of my slowest measured download speed online)
Highest: 70% - 100% (Give Ooma Telo 586 kbps Up, again much more than needed but just testing now)
Low: 3% - 69%
Inbound
Max Bandwidth: 10752 (70% of 15 Mbps [since I don't want to exceed 16 Mbps due to router processor limitations])
Highest: 10% ( Give Ooma Telo 1075 kbps Down, again much more than needed but just testing now)
Low: 90%

QoS Classification Screen

Created a Match Rule using the MAC Address of the Ooma Telo's Internet NIC Port. Set to TCP/UDP. Set to Any Port. Set Class to Highest. Set Description: Ooma Telo. Clicked Add button. Created another Match Rule setting Any Address, Any Port, Class: Low, Description: All other traffic. Clicked Add button. Deleted all other Rules.

Yesterday evening around 9:00 PM CST, I was getting about an 80ms reduction in delay / latency using this setup compared with the day before yesterday evening around 8:00 PM CST using the modem->telo->router with telo QoS turned on. Granted it wasn't hour v.s. hour comparison but still was only about an 1 hour difference.

My delay as of 9:00 PM CST yesterday in a single test call to 909 with 3 pencils taps was: 618ms, 615ms, 606ms.
#70131 by nn5i
Sat Dec 04, 2010 2:04 pm
I have found experimentally that power-cycling the Telo sometimes affects the latency. I conjecture that, at power-up, the Telo establishes a path between it and the Ooma servers, and establishes a new path at power-on reset. But this may be nonsense.

Still, a power-cycle of the Telo does seem to change the latency -- sometimes for the better, sometimes for the worse.
#70133 by wristwatch
Sat Dec 04, 2010 3:06 pm
nn5i wrote:I have found experimentally that power-cycling the Telo sometimes affects the latency. I conjecture that, at power-up, the Telo establishes a path between it and the Ooma servers, and establishes a new path at power-on reset. But this may be nonsense.

Still, a power-cycle of the Telo does seem to change the latency -- sometimes for the better, sometimes for the worse.


Thanks for the tip. My telo has been through several power cycles over the last several days and the delay remains at unacceptable levels (worse than cellphone latency). It seems like Ooma servers need more processing power to reduce the latency, but that is just a guess.
#70167 by seniorusn
Sun Dec 05, 2010 8:17 pm
wristwatch - does it matter if both MAC addresses are listed in the QOS settings of the router? I have my Ooma Telo setup as such - modem - router - ooma telo - I never set it up the other way they suggest in step 2a - so I have never gone into any of the Telo settings - but so far the quality is excellent.
THanks
#70174 by wristwatch
Mon Dec 06, 2010 4:56 am
seniorusn wrote:wristwatch - does it matter if both MAC addresses are listed in the QOS settings of the router? I have my Ooma Telo setup as such - modem - router - ooma telo - I never set it up the other way they suggest in step 2a - so I have never gone into any of the Telo settings - but so far the quality is excellent.
THanks


If you are not having quality problems, then there would probably be no need make changes to your setting. However, only the MAC address of the Internet NIC is need in the QoS settings on the router if your setup is modem->router->telo. The MAC address of the Home Network NIC is useless since there are no devices attached on your Telo's Home Network Port.

Who is online

Users browsing this forum: No registered users and 10 guests