Need extra help installing your Ooma Hub or Telo system? Let us know.
#41623 by indie_dev
Wed Jan 13, 2010 6:39 am
This assumes you have the following:

- Ooma device (Hub or Telo)
- D-Link DIR-655 router (will work for any router, assuming you know how to use the similar features of your router)
- DSL or Cable modem

STEP 1

  1. Open your browser and go to 192.168.0.1 to access the routers config page. Login
  2. Go to SETUP, then NETWORK SETTINGS and ensure that "Enable DHCP server" is checked
  3. Scroll down the page and ensure that "Add DHCP Reservation" is checked
  4. make sure that your computer's LAN networking (depending on your OS, go to the Networking applet) is set to obtain an IP via DHCP. Even if you gave it a static IP address before, change it back to DHCP - you can change it back later when everything works as it should

STEP 2

  1. plug the computer's LAN cable (currently plugged into the router or switch) into the Home port on the Ooma. If anything is plugged in the Ooma INTERNET port, unplug it for now.
  2. open up your browser and go to 172.27.35.1 (this is the IP address of the Ooma device and you can use setup.ooma.com as well)
  3. in the Ooma settings, go to NETWORK and change it from Automatic to DHCP, then change "MODEM Port MAC Address" to "Use Built in" then click UPDATE.
  4. WRITE DOWN the MAC address that is next to the "Use Built in" option you just enabled
  5. in the Ooma settings, go to ADVANCED, make sure there is nothing in DMZ, then add a new port forwarding TCP rule for port 80 and forward it to 172.27.35.1, set (to disable Ooma QOS) "Upstream Internet Speed" to 0, click UPDATE.

STEP 3

  1. unplug the router power
  2. unplug the Ooma power
  3. unplug the modem power
  4. unplug the computer LAN cable from the Ooma HOME port and put it back into your router (where I assumed it was before in one of the Blue ports)
  5. plug the [Black] Ooma LAN cable into the Ooma INTERNET port and the other end into one of the four [Blue] ports on the router.

count to 10 seconds

STEP 4

  1. plug in the modem power, wait for it to fully init
  2. plug in the router power, wait for it to fully init
  3. plug in the Ooma power, wait for it to fully init - it will be blank at first, then start to cycle Blue, then it will go to Red. Leave it alone for a bit. If all goes well, it will obtain an IP address from the router

STEP 5

  1. Open your browser and go to 192.168.0.1 to access the routers config page. Login
  2. Scroll down the page to the "Number of Dynamic DHCP Clients" section and look for the modem MAC address of the Ooma device. You wrote this down back in Step 2. That is the IP address of the Ooma device as assigned by the router.
  3. Reserve that address - so that it never changes. So, click on reserve next to the IP address that is assigned, then scroll up back to the "Add DHCP Reservation" section. The information you reserved has been entered for you. There won't be any "Computer Name" in the first box, so just enter Ooma Device as the identifier. Click SAVE.
  4. Make a note of the reserved IP address since thats the ONLY way that you will be able to access the Ooma config page because neither 172.27.35.1 nor setup.ooma.com will work due to the fact that the Ooma device a) is no longer connected via the HOME port b) the Ooma device has a different internal IP mask than what the router is assigning.

Assuming all went well, your Ooma device should be all Blue (if not, press the top middle button until it is all bright enough to see). You can now also access the Ooma device via the reserved IP address from Step 5.

QOS:

Very straight-forward. Since you have a top-of-the line router, it can do better QOS than the Ooma device.

  1. Open your browser and go to 192.168.0.1 to access the routers config page. Login
  2. Go to ADVANCED and click on QOS ENGINE
  3. Enable these: Enable Traffic Shaping, Automatic Uplink Speed, Enable QoS Engine, Automatic Classification
  4. Disable these: Dynamic Fragmentation
  5. Set Connection Type to be whatever your network is (cable, DSL etc)
  6. Go to QOS Engine Rules and set one for the Ooma device as follows: Name: Ooma VOIP, Priority:50, Protocol: Any, Local IP Range: in both boxes, enter the IP address reserved and assigned to the router, Remote IP Range: No change here, Local Port Range: No change here, Remote Port Range: No change here
  7. Check the box to the left of Local IP Range to enable this QOS rule
  8. SAVE the settings - wait for the router login window to come back

STEP 6

Open your browser and enter the IP address assigned to the Ooma device and you should now be able to view the Ooma setup screen (due to the fact that port 80 on the device has been forwarded to the primary IP address of the device). You might want to add it to your bookmark favorites.

Be Happy.
Last edited by indie_dev on Wed Jan 13, 2010 10:49 am, edited 5 times in total.
#41681 by Bill D
Wed Jan 13, 2010 1:00 pm
indie_dev - - Great job on your very well-written guide.

I've had my DIR-655 configured with two Ooma Hubs behind it exactly as you suggest for the last two months and the call quality on both Hubs remains excellent even during heavy Internet traffic.

However, I have one comment on your guide: Why do you recommend setting the QOS Priority to "50" instead of "1"?

Why would anyone not want their VOIP to always have the highest Priority? Setting it to "50" leaves the possibility of the user setting the Priority of another IP device higher (less than 50).

Bill
#41685 by indie_dev
Wed Jan 13, 2010 1:25 pm
Bill D wrote:However, I have one comment on your guide: Why do you recommend setting the QOS Priority to "50" instead of "1"?

Why would anyone not want their VOIP to always have the highest Priority? Setting it to "50" leaves the possibility of the user setting the Priority of another IP device higher (less than 50).

Bill


By default, most web/smtp/mail traffic have a priority of around 128. So as a rule, don't set anything lower than 50 for the best performance. I've seen reports of people using 1, because they think that makes it better. It doesn't. Setting it to 1 just reduces the router's performance because internally it is already doing QOS traffic shaping for default services.

e.g. I use MagicJack for international calls because the rates are cheaper than Ooma's and TELNA (my LD carrier on land line), so I have two QOS settings for the MJ in the router and set them both to 55 and 60. This way, at 50, Ooma (which I use more often) has top priority the MJ which I don't use very often.
#41698 by Bill D
Wed Jan 13, 2010 2:01 pm
indie_dev - - Thanks for the info. I've changed my Priority to 50.

Since you're on top of the DIR-655's QOS operation, I have a question - I changed from a cable modem to AT&T U-verse a few days ago and I noticed my DIR-655's "Measured Uplink Speed" shows a whooping 5846 Kbbs even though all the speed test sites only measure about the same speed as AT&T's advertised 1500 Kbps uplink speed (I have U-verse 18 Mbps service).

Previously, with my cable modem, the DIR-655 always measured the uplink speed around 750 Kbps (the same as the speed test sites measured it).

What's up with the DIR-655's bogus speed measurement on U-verse? Should I manually set my QOS Uplink Speed in the DIR-655 to avoid trouble with Ooma calls during high Internet traffic?

Bill
#41707 by indie_dev
Wed Jan 13, 2010 2:18 pm
Bill D wrote:indie_dev - - Thanks for the info. I've changed my Priority to 50.

Since you're on top of the DIR-655's QOS operation, I have a question - I changed from a cable modem to AT&T U-verse a few days ago and I noticed my DIR-655's "Measured Uplink Speed" shows a whooping 5846 Kbbs even though all the speed test sites only measure about the same speed as AT&T's advertised 1500 Kbps uplink speed (I have U-verse 18 Mbps service).

Previously, with my cable modem, the DIR-655 always measured the uplink speed around 750 Kbps (the same as the speed test sites measured it).

What's up with the DIR-655's bogus speed measurement on U-verse? Should I manually set my QOS Uplink Speed in the DIR-655 to avoid trouble with Ooma calls during high Internet traffic?

Bill


Whoa!! This is scary! Just this morning a friend of mine sent me an IM with the *same* issue.

Basically the router doesn't [yet] know how to measure it because of how U-Verse (coming soon my area!) throttling works. I suspect that D-Link will fix it in an upcoming firmware update.

So your best bet is to disable the Automatic Uplink Speed in the router, then manually set your uplink speed to either about 15% less than the 1500 Kbps U-Verse rated speed -or- "worst of three" uplink speed test results you get.
#42297 by Bill D
Sun Jan 17, 2010 12:18 pm
indie_dev - - FYI - - Here's an update on the DIR-655's automatic measurement of U-verse uplink speed.

When my U-verse router was installed 6 days ago, the installer left it with its default config (which gave me double NAT) and he simply slid it in place of my old Cable modem.

Everything worked great except for my DIR-655's automatic "Measured Uplink Speed" being very high - as we discussed and your friend also noticed.

Today I had time to look at the U-verse config and changed it to pass through all incoming IP traffic to my DIR-655 (what AT&T calls "DMZ Plus" mode) and now the DIR-655's automatic uplink speed measurement works correctly, consistently showing 1575 Kbps.

As you suggested, the U-verse router may do some tricks with throttling that makes the auto-test results higher. But it looks like their "DMZ Plus" mode kills those tricks.

The U-verse wireless router looks interesting, but I strive to not fall in love with any gear that I lose if I cancel service. That way I can quickly and easily switch back and forth between "dumb pipe" suppliers based on price/performance.

Bill

Who is online

Users browsing this forum: No registered users and 10 guests