Need extra help installing your Ooma Hub or Telo system? Let us know.
#55984 by sgamer
Tue May 18, 2010 9:20 pm
I installed the Telo per ooma's recommendation but everything is excruciating slow behind the Home Network port. I've tried it between the cable modem and router and the network just crawled. Now I have my laptop directly connected and again it's so slow that it is unusable. I should note that the phone seems to work fine and was up and running within minutes. Anything that I plug into the Home port is unusable (and I'm not exaggerating). It even failed to hand off an IP address to my laptop and had to release the MS default IP and renew. Once I did that, I did some testing with my PC behind my router and my laptop behind the Telo. I ran the "" speed tests.

Another thing is the power connector is very loose if it matters. I saw another post that I'll follow up on for that but at this point I think I have a bad Telo. However I'm not opposed to any suggestions.

PC - results were great, all green.

VoIP test statistics
Jitter: you --> server: 0.3 ms
Jitter: server --> you: 1.2 ms
Packet loss: you --> server: 0.0 %
Packet loss: server --> you: 0.4 %
Packet discards: 0.0 %
Packets out of order: 0.0 %
Estimated MOS score: 3.9

Speed test statistics
Download speed: 2997048 bps
Upload speed: 1056520 bps
Download quality of service: 96 %
Upload quality of service: 99 %
Download test type: socket
Upload test type: socket
Maximum TCP delay: 69 ms
Average download pause: 11 ms
Minimum round trip time to server: 72 ms
Average round trip time to server: 72 ms
Estimated download bandwidth: 31200000bps
Route concurrency: 10.410244
Download TCP forced idle: 77 %
Maximum route speed: 7281664bps

Laptop - Sucks

After the third refresh, the page loaded. I ran the test and it failed 3 of five catagories.

VoIP test statistics
Jitter: you --> server: 0.4 ms
Jitter: server --> you: 3.6 ms
Packet loss: you --> server: 34.2 %
Packet loss: server --> you: 18.6 %
Packet discards: 0.0 %
Packets out of order: 0.0 %
Estimated MOS score: 3.5

Speed test statistics
Download speed: 166016 bps
Upload speed: 3160 bps
Download quality of service: 1 %
Upload quality of service: -- %
Download test type: socket
Upload test type: HTTP
Maximum TCP delay: 2268 ms
Average download pause: 96 ms
Minimum round trip time to server: -- ms
Average round trip time to server: -- ms
Estimated download bandwidth: 560000bps
Route concurrency: 3.373169
Download TCP forced idle: --
Maximum route speed: --
#55989 by sfhub
Tue May 18, 2010 11:12 pm
Given what you said, it is doubtful your Telo is bad.

I think you are confusing "unusable" slow with misconfigured network.

I suggest you go in ooma setup pages and configure it to use the builtin mac address.

Then go and reboot the cable modem then reboot the Telo.

On your PC or laptop do a DHCP release/renew.

If you ever change the device connected to your cable modem, usually you have to reboot the cable modem or the connection won't be usable. The cable modem usually locks onto the first device it sees and only allows that device to use the Internet. Rebooting allows it to pick up a new device.
#56092 by sgamer
Wed May 19, 2010 8:07 pm
I left out all the minutia of everything I've done as it tends to get rather wordy. Maybe I should have mentioned that I'm a network engineer with about 20 years experience. The Telo is a simple piece of equipment and, unless there's an advanced mode I'm not privy to, it is difficult to screw up the configuration. But, as I stated, I'm open to suggestions.

I did read about it's default MAC address setting of "auto" and changed that to use the "built in" long ago even though it showed that it was already using it's burned in address.

I am well aware of rebooting devices and usually go overboard. I did power cycle the cable modem, the router and the Telo whenever I made a change and I did power them up sequentially starting with the modem. In the case mentioned in my original post, the laptop was completely shut off before I plugged it in to the Telo which, by the way, was connected with a known good patch cable which was also different than the two cables used when trying to connect the Telo between the router and modem. I have brand new cables up the wazoo since every Cisco router or switch we buy comes with one or more.

When booting the laptop, the Telo DHCP failed to assign an address so as I stated, I had to release the MS default address that gets assigned when DHCP fails and renew just to get an IP address. Maybe I didn't wait long enough for the Telo to boot up but I think a few minutes should be sufficient. It sits on top of my computer armoire where I cannot see the lights but I think a few minutes would be all that is required. However I am willing to chalk it up to not waiting long enough for it to boot. I'll make sure it's booted next time I power up my laptop however this has nothing to do with the performance problem, at best it's only a symptom of a larger port problem or Telo failure.

The fact is that so far everything that I've plugged into the Telo Home Network port experiences excruciatingly slow network performance which testing proved to be about a 35% packet loss. I think it's very likely I have a faulty Telo but thought I'd ask in case there is something I'm missing. I've been in the networking business long enough to know there can be something I don't know or missed. I'll check everything again and verify I didn't do something stupid but at this point it sure seems to me that the Home port is faulty. The power connector is definitely loose too.
#56099 by murphy
Thu May 20, 2010 2:05 am
Set both QOS values in the Telo to 0 and rerun your tests.
#56217 by sgamer
Thu May 20, 2010 8:40 pm
I've been trying to work with ooma's tech support in conjunction with this thread. I had a recent experience with Phone Power's tech and sales support which was so bad I decided to go with ooma which has many bad ratings and currently holds a grade of "F" on the BBB site. I figured it couldn't be any worse but I'm thinking I was wrong. After telling them how bad the performance is for anything connected to the Home Network connection, their response was "Whatever speed you get on the Home network port is unfortunately normal." That's bull and this thing is going back to Best Buy.

Without the Telo, test results are routinely 9Mbps down / 1Mbps up for my cable connection. With my PC or laptop connected to the Telo Home Network port (and a variety of new patch cables used) I am not even able to complete dslreports speed test because it loses too many packets. In fact, even accessing the Telo setup page is way quicker from the Internet port than from the Home Network port.

My question to anyone reading this is whether anything connected to your Home Network port is "normal" like mine?

Test performed on

PC --> Router --> Cable Modem (NO Telo):
Download speed: 2,997,048 bps
Upload speed: 1,056,520 bps
Packet loss: you --> server: 0.0 %
Packet loss: server --> you: 0.4 %

Telo --> Router --> Cable Modem:
Download speed: 166,016 bps
Upload speed: 3,160 bps
Packet loss: you --> server: 34.2 %
Packet loss: server --> you: 18.6 %

Telo --> Cable Modem:
Download speed: 49,744 bps
Upload speed: 1,616 bps
Packet loss: you --> server: 38.2 %
Packet loss: server --> you: 0.2 %

Who is online

Users browsing this forum: No registered users and 7 guests