Problems using My Ooma? Ideas on how we can make it better? You’ve come to the right place.
#47776 by harleyjess
Fri Feb 19, 2010 8:05 am
I registered the OOMA handset and it worked fine for a couple of days- this morning-the handset is dead-- nothing on the screen , when on charger blue light says charging- phone wont turn on ???????I disconnected battery and replugged in and same thing
#47794 by mthomtech
Fri Feb 19, 2010 11:21 am
When you plug the phone into the charger do you hear the beeps that indicate it's plugged in? Have you tried another USB charger if you have one?

May be a defective battery. I'd call Tech Support to see if they'll send you a new one.
#47869 by inrame
Fri Feb 19, 2010 6:35 pm
won't do anything if you really don't have power, but maybe try a hard reset... hold the zero and left-soft-key down while trying to power it up.
#47894 by fastlane01
Sat Feb 20, 2010 5:27 am
All 3 of my handsets are dead this morning. I thought this was a thing of the past with the latest firmware it had, but now all dead again.

I even tried having Batteries Plus make an exact duplicate of battery, wondering if it is defective batteries and that one is dead, too.

Ooma obviously should have not gotten in the handset business - two rj-11 jacks on the Telo would have been cheaper and less frustrating, or how about a two line jack?!
#47898 by murphy
Sat Feb 20, 2010 6:11 am
I could be wrong but it appears that once a handset is put on the charging stand and fully charges the battery the charger is turned off in spite of the blue LED. The handset can then run on battery until it is dead without charging ever being resumed.

I have a Panasonic cordless phone that does the same thing.
Last edited by murphy on Sat Feb 20, 2010 6:34 am, edited 1 time in total.
#47899 by Groundhound
Sat Feb 20, 2010 6:22 am
Place the non-responsive handsets in their cradles and then press the red "end call" key to start them - they should turn on and start charging. Allow them to charge for several hours before removing from the cradle.
#48017 by Morpheus
Sun Feb 21, 2010 2:37 pm
I have one handset that is doing this. The screen just goes dead and the blue light is on indicating the phone is charging. Fails to see incoming calls.

What is the problem. Do I need to replace the hand set?
#48028 by fastlane01
Sun Feb 21, 2010 5:21 pm
Two of mine are utterly dead unless I take the batteries and move them around so that the last remaining charging one gets the batteries back to life. Very weird, not sure if it is hardware or what, but this just started 2 days ago - for 2 months all was fine. SO, not at all like the behavior of charger turning off and pressing the red key doesn't affect it until a new battery is in.
#48032 by Morpheus
Sun Feb 21, 2010 5:41 pm
This is the second time it has done this in the last few days. I'm ordering another one and returning this one to see if that helps.
#48134 by Tomcola
Mon Feb 22, 2010 11:12 am
My handset did the same routine twice within the last 7 days. I tried removing the battery and replacing it and then only a power down and up of both the handset and the Telo brought it back. Between this action, the inability of the handset to download contacts and the lack of response to my emails to Support, I'm thinking my $35 Uniden DECT 6.0 set of 3 portables was a smart move.

Who is online

Users browsing this forum: No registered users and 5 guests