Got something else to discuss that is not covered by the previous forums? Post it here!
#65540 by Gregable
Sun Sep 26, 2010 10:46 am
I have a business-class cable (comcast) modem setup at home. It's pricey but has a fat pipe. I get 20Mb down and 10Mb up. That is measured, not advertised. Way more than Ooma needs. Behind the comcast modem, I have a Linksys WRT610N wireless router with wired ports as well. Everything in my home plugs into that router (or is wireless) including the ooma and several computers, so there is nothing "behind" the Ooma. I have not configured QOS on that router in any way.

I have two computers - a laptop and a desktop. When no phone calls are in progress, both connect to the internet flawlessly. When a phone call is in progress, my laptop works fine and my desktop is completely disconnected - I can't ping, I can't reach websites in my browser, etc. Again, Both the laptop and desktop are plugged into the linksys router in the same configuration so to the router they are the same setup. Furthermore, I dual boot the desktop into both Windows 7 and Ubuntu - both OSes seem to have the same issue during a phone call. Last little detail, during phone calls my desktop can resolve hostnames (DNS), so it seems like UDP packets go through fine but TCP is blocked.

What could possibly explain this? I'm out of ideas - it's not the router since other machines are fine. It's not some OS setting since two different OS'es are affected. It's TCP only. There is plenty of bandwidth. Ooma isn't in front of my machine in the network. Any ideas? Bonus points if you know how to fix this.
#65543 by WayneDsr
Sun Sep 26, 2010 12:34 pm
Is your desktop wired? Older cordless phones can interfer with wireless routers. I'm going to assume your desktop is wired, though.

The other thing I can think of would be ooma and your desktop sharing the same IP address by accident. When a call is in progress ooma takes over the ip address and kills the pc connection.

Wayne
#65544 by Nat Ray
Sun Sep 26, 2010 12:49 pm
WayneDsr wrote:The other thing I can think of would be ooma and your desktop sharing the same IP address by accident. When a call is in progress ooma takes over the ip address and kills the pc connection.


I am on the same page as WayneDsr. Have you tried taking Ooma totally out of the equation? If Ooma is setup to automatically generate an IP, it may be trying to spoof your router. Set Ooma to use its default IP . . .

Best regards,
Nat Ray :cool:
#65553 by Gregable
Sun Sep 26, 2010 3:40 pm
Both the Ooma and the desktop are wired as is the other laptop which still works during calls, I don't use wireless much.

There may be something to the sharing ip address theory. My router uses DHCP, so the Ooma should just get a unique local ip from that though right? My ooma's MAC address doesn't show up in my routers DHCP client table, although the desktop does. Even if I do place a call, I still don't see my Ooma's MAC address in the DHCP client table. Not sure what that means or how to fix it, it is odd.
#65554 by Gregable
Sun Sep 26, 2010 4:04 pm
I tried another experiment - I plugged in another computer behind the ooma (ooma "home" port). That other computer thought it's local ip address was 192.168.1.5 as did the desktop that is having this trouble, so yes my router is assigning both devices the same ip. I went in and assigned my desktop a new statically allocated ip and the ooma picked up this new ip too. I'm not sure why this keeps happening or how to fix it. :?
Last edited by Gregable on Sun Sep 26, 2010 5:30 pm, edited 1 time in total.
#65555 by tommies
Sun Sep 26, 2010 4:07 pm
You need to tell the Telo to use its (Modem/to Internet port) build-in MAC address. You notice of missing telo MAC address in the router DHCP table is an indication that the telo is spoofing your pc's MAC address for its Modem port. Hence both have the same ip.

You need to (temporary) connect a laptop/pc by wire to the telo HOME port, and then point your browser to http://setup.ooma.com or http://172.27.35.1 . Click on the Network tab and change telo to use it build-in MAC then click update. If the link does not work, you need to reboot your pc/laptop, but I usually don't have to.
#65556 by Nat Ray
Sun Sep 26, 2010 4:18 pm
Nat Ray wrote:I am on the same page as WayneDsr. Have you tried taking Ooma totally out of the equation? If Ooma is setup to automatically generate an IP, it may be trying to spoof your router. Set Ooma to use its default IP . . .


I am going to have to take a hit on this, the post should have read:

I am on the same page as WayneDsr. Have you tried taking Ooma totally out of the equation? If Ooma is setup to automatically generate a MAC Address, it may be trying to spoof your router. Set Ooma to use its default MAC Address . . .

Using a patch cord, attach a computer using DHCP to Ooma's Home Port
At the Run command type: http://setup.ooma.com/ and hit the Enter Key
This will take you to Ooma's web interface
Under Settings, select Network
Under MODEM Port MAC Address, select Use Built in:
Select Update

Note the MAC Address . . . You will see it in connected devices on the router

Hope this helps . . .

Best regards,
Nat Ray :cool:
#65557 by Nat Ray
Sun Sep 26, 2010 4:24 pm
Great job Tommies . . .

Best regards,
Nat Ray :cool:
#65563 by Gregable
Sun Sep 26, 2010 5:18 pm
Ah, that does it. Thank you all so much!

It never occurred to me that the ooma would be spoofing the mac of the machine that first connected to it. I also assumed the probability of a random mac collision would be infinitesimal. I bet some of my dropped Ooma calls might have to do with this as well.
#65564 by Nat Ray
Sun Sep 26, 2010 5:23 pm
Gregable wrote:Ah, that does it. Thank you all so much!


F A N T A S T I C . . . You are quite welcome . . .

Best regards,
Nat Ray :cool:

Who is online

Users browsing this forum: No registered users and 10 guests