Got something else to discuss that is not covered by the previous forums? Post it here!
#13410 by wrgleim
Sat Jul 18, 2009 11:54 am
I have 2 imacs and several PCs around the house networked via ethernet. If I connect my ooma hub in front of my belkin or netgear wireless router, my pc's work fine, but my iMacs (one powerpc and the other intel) will not allow me to stream Hulu. Also, I can't perform the speedtest.net exercise on the imacs when my system is connected this way (I can see the download speed 14mps, but the upload test freezes and I have to force quit my browser- firefox or safari.) My pc's work fine. If I connect my ooma hub after the wireless router, both PCs and iMacs work great. Problem is that I experience echo problems on my calls both inbound and outbound. Please help.
#13419 by ggilman
Sat Jul 18, 2009 6:02 pm
I currently have my ooma before my router (modem->ooma->router). Running my intel mac (latest macbook pro), I have not noticed it behave any differently than my PCs. I can't say for certain I've streamed hulu or run the specific speed test you mention from the mac, but haven't noticed any other issues. To be certain, I'll look at hulu and speedtest.net a little bit later tonight and post my results.
#13420 by ggilman
Sat Jul 18, 2009 6:49 pm
Just ran both tests on my macbook pro. Grabbed a random hulu stream and it played just fine. Speedtest.net bandwidth test worked without issue as well. I'm not sure why passing traffic through the ooma would cause issues like you are seeing.
#13423 by Aveamantium
Sat Jul 18, 2009 8:34 pm
wrgleim wrote:I have 2 imacs and several PCs around the house networked via ethernet. If I connect my ooma hub in front of my belkin or netgear wireless router, my pc's work fine, but my iMacs (one powerpc and the other intel) will not allow me to stream Hulu. Also, I can't perform the speedtest.net exercise on the imacs when my system is connected this way (I can see the download speed 14mps, but the upload test freezes and I have to force quit my browser- firefox or safari.) My pc's work fine. If I connect my ooma hub after the wireless router, both PCs and iMacs work great. Problem is that I experience echo problems on my calls both inbound and outbound. Please help.

Log onto setup.ooma.com and go to the Advanced tab and put the IP address assigned by ooma to your router in ooma's DMZ. Should be something like 172.27.35.X (it will not be 172.27.35.1 as this is the IP of the home port and you Do Not want to put this address in ooma's DMZ unless it is behind your router and not in front of it).

By the way you can force a certain IP to your router by putting this IP in both the starting and ending DHCP range. You'll likely have to power cycle both the ooma and router (ooma first) for these changes to take effect.
#13712 by wrgleim
Tue Jul 21, 2009 7:42 pm
ggilman wrote:Does the Mac issue only present itself when you are talking on the phone over the ooma, or even when not using the phone?

No, it doesn't matter weather I'm using the phone or not. So I can not view streaming video from hulu, cbs, or nbc websites. Quicktime and Youtube work fine. I've not tried to attach my iMacs directly to ooma hub. That may be a way of further isolating the problem. It's tough to find a time in my household where I'm not interrupting one of the family's phone calls or surf time...
#13713 by wrgleim
Tue Jul 21, 2009 7:47 pm
Aveamantium wrote:
wrgleim wrote:I have 2 imacs and several PCs around the house networked via ethernet. If I connect my ooma hub in front of my belkin or netgear wireless router, my pc's work fine, but my iMacs (one powerpc and the other intel) will not allow me to stream Hulu. Also, I can't perform the speedtest.net exercise on the imacs when my system is connected this way (I can see the download speed 14mps, but the upload test freezes and I have to force quit my browser- firefox or safari.) My pc's work fine. If I connect my ooma hub after the wireless router, both PCs and iMacs work great. Problem is that I experience echo problems on my calls both inbound and outbound. Please help.

Log onto setup.ooma.com and go to the Advanced tab and put the IP address assigned by ooma to your router in ooma's DMZ. Should be something like 172.27.35.X (it will not be 172.27.35.1 as this is the IP of the home port and you Do Not want to put this address in ooma's DMZ unless it is behind your router and not in front of it).

By the way you can force a certain IP to your router by putting this IP in both the starting and ending DHCP range. You'll likely have to power cycle both the ooma and router (ooma first) for these changes to take effect.

I tried to execute your instructions. I couldn't really come up with the IP address assigned by the ooma hub to my router. I expected a screen similar to my router that listed attached divices by name. Instead, I found several references to a 172.27... via the advanced tab (as i recall). I tried entering it into the DMZ, but I didn't see any improvement. Thanks for the suggestions...
#13717 by bw1
Wed Jul 22, 2009 4:18 am
If you want to put your Ooma hub before your router, you can make the connections and then go to http://setup.ooma.com/
There on the advanced page, you'll see under Home Port IP Address - 172.27.35.1 and under DHCP Configuration Start and End Address, you'll see 172.27.35.X to 172.27.35.Y.

If you change X and Y to be the number 2, then the IP address assigned to your router will be 172.27.35.2. You can then also enter 172.27.35.2 into the DMZ on the same page.

You'll probably need to reboot your router after making this change.

You can also see the IP address assigned to your router somewhere on your router's configuration pages. How to access that would depend on your router.

I'm not sure that doing this will improve your mac's performance. I'm not sure why those are having problems and your PC's aren't.
#13720 by ggilman
Wed Jul 22, 2009 5:40 am
Are the Macs using the exact same network setup as the PCs? For example, are you using a proxy, DHCP vs. static addresses, etc... differently between the devices? It almost has to be some difference like that.

PCs/Macs can potentially behave differently with local network resources (access to TCP printers, network shares, etc...) but when it comes to what is put out on the Internet, the packets should be identical & thus the ooma should not affect this traffic differently. If systems behaved differently on the Internet, the Internet wouldn't work at all. When going through the ooma, all it should do is change enough packet information to perform NAT, which does not affect the data contents, just addressing information. When on the phone, ooma can potentially also delay or drop packets based on QoS, but if not on the phone, ooma does not perform any QoS functions & since you say it is identical behavior either way, it's not a QoS issue.

Anyway, the ooma should make no differentiation between a Mac or PC. Verify that the network settings are identical between your Macs and PCs. There are network settings that could cause issues with an extra "hop" between you and the net. Otherwise, assuming all machines are using identical DHCP with no proxies (or at least identical settings between them, whatever they happen to be), I cannot see why a Mac would act differently than a PC with respect to sending data through an ooma.

One last thought, what browser are you using on the Mac? Should not make a difference, but if you are using Safari, you might try another browser like Firefox. The browser itself really shouldn't matter, but potentially there is some network setting tucked away in the browser that could and trying a different browser will test this.
#13721 by ggilman
Wed Jul 22, 2009 5:50 am
Did think of one more thing... MTU size. This can cause strange errors similar to what you are reporting. Potentially the ooma could have a MTU size mismatch with your Mac boxes causing excess packet fragmentation.

No clue how to change that on a Mac or even see what it is set to. I've done it on a PC but I'd even have to look that up.

If I recall, the ooma picks up an MTU size based solely off of the type of Internet connection you have (cable vs. dsl). There is no way to change it on the ooma. You should be able to change it on the Mac though if you can determine that the size is an issue.

Anyway, sorry I can't be more help on the details, but if you google "MTU" and "packet fragmentation", you should find out how to check your MTU size on the Macs & PCs and see if they differ. I believe it is shown on the ooma's setup status page. Ideally your Macs, PCs, router, and ooma all have the same MTU. Being slightly different may be OK, (in my case, they are different between my PC and ooma but works fine) but I've read accounts (completely unrelated to ooma) where packet fragmentation causes issues just like what you are experiencing.

Who is online

Users browsing this forum: Google [Bot] and 11 guests