Got something else to discuss that is not covered by the previous forums? Post it here!
#13521 by Aveamantium
Mon Jul 20, 2009 8:30 am
babs wrote:AVS thanks for the quick reply.

When you said router you meant Dlink...not the OOma hub?

And also what exactly you mean what IP ooma assigns wan port? isn't 127.27.36.5 (IP of my router) as mentioned in my example?

Thanks,
-Babs

I just pinged 127.27.36.5 and got a response so that IP address is the Public IP that is assigned to your router by your ISP. Your router should then assign a Private IP (something like 192.168.1.x) to the ooma. You may have to connect a laptop to the home port of the ooma to check what IP is assigned to the ooma's WAN port (setup.ooma.com) if your Dlink doesn't tell you what the attached devices are (I'm not familar with Dlink). This IP is what you want to put into the DMZ of the router. However, if you're not experiencing one way audio I don't know if I would bother with it.

Edit: By the way, yes I meant the Dlink when I said router...
#15406 by jimjr
Mon Aug 10, 2009 11:02 am
Kneo wrote:Hello all,

I am new to OOMA. Just installed it on Sunday and so far we are loving it. I have OOMA hooked directly to my cable modem and my DLink DGL-4500 Router hooked to OOMA. One of the devices I have wired into the DGL-4500 router is a Windows Home Server Box.

Ever since I hooked up OOMA I have not been abled to remote access the home server. I can still access it through internally however.

Can anyone tell me what may be causing this and suggest a fix?

Thank you


I'm not sure if your question is still unanswered, but I have a WHS that I was able to get back out to the Internet through the Ooma hub. Here's how you do it. First, go into the router's set up and write down the three ports you are forwarding through the router to get to the WHS. It's 80, 443, and one other if I remember correctly. Disregard the IP address for the WHS. You don't need that info to configure the ooma. Second, find the router's WAN IP address in the general settings and write it down as well. Third, go to the ooma setup menu and forward all three ports, one by one, to the WAN IP address for the router. What you are essentially doing is telling the ooma hub to forward the three ports to the router's doorstep. Then the router will forward the same three ports to the IP address for the WHS. What was screwing things up is that you were probably trying to forward the ports directly from the ooma to the IP address for the WHS, and the ooma will not recognize that IP address. You'll get an out of range error.

You can use the same procedure for configuring a Slingbox, for example, as well. Just forward the necessary port to the router's WAN IP address, and then let the router take it from there. As long as you did not change any of the port forwarding information in the router itself, it should work just as it did before putting the ooma between the modem and the router.

Hope this helps.
#15408 by Aveamantium
Mon Aug 10, 2009 11:14 am
jimjr wrote:I'm not sure if your question is still unanswered, but I have a WHS that I was able to get back out to the Internet through the Ooma hub. Here's how you do it. First, go into the router's set up and write down the three ports you are forwarding through the router to get to the WHS. It's 80, 443, and one other if I remember correctly. Disregard the IP address for the WHS. You don't need that info to configure the ooma. Second, find the router's WAN IP address in the general settings and write it down as well. Third, go to the ooma setup menu and forward all three ports, one by one, to the WAN IP address for the router. What you are essentially doing is telling the ooma hub to forward the three ports to the router's doorstep. Then the router will forward the same three ports to the IP address for the WHS. What was screwing things up is that you were probably trying to forward the ports directly from the ooma to the IP address for the WHS, and the ooma will not recognize that IP address. You'll get an out of range error.

You can use the same procedure for configuring a Slingbox, for example, as well. Just forward the necessary port to the router's WAN IP address, and then let the router take it from there. As long as you did not change any of the port forwarding information in the router itself, it should work just as it did before putting the ooma between the modem and the router.

Hope this helps.

If you DMZ the router's WAN IP in ooma then you can bypass the ooma's firewall alltogether. Then all you have to deal with is the port forwarding on the router. I think the port you're looking for is Port 1723 TCP. You may also need port 47 GRE forwarded on some routers (or have GRE "helpers" enabled).

By the way, welcome to ooma jimjr! :)
#15410 by Aveamantium
Mon Aug 10, 2009 11:21 am
By the way jimjr are you hosting a website? I'd be really carefull forwarding Port 80 to your home server as this is the most commonly attacked port out there (Sorry if you already know this)! The only ports I forward to my SBS2003 Server for remote access is 443 (Access everything using SSL), 47 GRE, and 1723 TCP. Of course this is for VPN/Sharepoint/Exchange, not sure how exactly how WHS works?
Last edited by Aveamantium on Mon Aug 10, 2009 11:27 am, edited 1 time in total.
#15412 by jimjr
Mon Aug 10, 2009 11:27 am
Aveamantium wrote:
jimjr wrote:I'm not sure if your question is still unanswered, but I have a WHS that I was able to get back out to the Internet through the Ooma hub. Here's how you do it. First, go into the router's set up and write down the three ports you are forwarding through the router to get to the WHS. It's 80, 443, and one other if I remember correctly. Disregard the IP address for the WHS. You don't need that info to configure the ooma. Second, find the router's WAN IP address in the general settings and write it down as well. Third, go to the ooma setup menu and forward all three ports, one by one, to the WAN IP address for the router. What you are essentially doing is telling the ooma hub to forward the three ports to the router's doorstep. Then the router will forward the same three ports to the IP address for the WHS. What was screwing things up is that you were probably trying to forward the ports directly from the ooma to the IP address for the WHS, and the ooma will not recognize that IP address. You'll get an out of range error.

You can use the same procedure for configuring a Slingbox, for example, as well. Just forward the necessary port to the router's WAN IP address, and then let the router take it from there. As long as you did not change any of the port forwarding information in the router itself, it should work just as it did before putting the ooma between the modem and the router.

Hope this helps.

If you DMZ the router's WAN IP in ooma then you can bypass the ooma's firewall alltogether. Then all you have to deal with is the port forwarding on the router. I think the port you're looking for is Port 1723 TCP. You may also need port 47 GRE forwarded on some routers (or have GRE "helpers" enabled).

By the way, welcome to ooma jimjr! :)


Thanks for the welcome. I tried DMZ'ing the router's WAN IP first, and for some reason it didn't take. I agree. It should have worked. But for some reason, it didn't for me. In any event, I kind of like the idea of having the ooma out in front of my router. The more obscure my system the better.

Actually, the third port I can't recall right now is 4xxx. But it's easy enough to locate. I'm just not at home right now so I can't pick it off my router's setup menu.
#15414 by jimjr
Mon Aug 10, 2009 11:33 am
Aveamantium wrote:By the way jimjr are you hosting a website? I'd be really carefull forwarding Port 80 to your home server as this is the most commonly attacked port out there (Sorry if you already know this)! The only ports I forward to my SBS2003 Server for remote access is 443 (Access everything using SSL), 47 GRE, and 1723 TCP. Of course this is for VPN/Sharepoint/Exchange, not sure how exactly how WHS works?


Good advice. I'll look at other configurations, but WHS isn't that sophisticated. Haven't heard of anyone using any other ports other than the one's I mentioned to configure remote access for WHS.

Edit: 4125 TCP is the third port. Aveamantium, you raise a good point. I think I'll can port 80 and just log in via https. I'm not hosting anything.
#15419 by Aveamantium
Mon Aug 10, 2009 11:45 am
Ahhh yes, forgot about 4125 TCP! You need that one for Remote Desktop to work! :) Yeah, I have just never felt all that comfortable with port 80 making it to my server. Hope it works for you (just using SSL).
#15431 by jimjr
Mon Aug 10, 2009 1:45 pm
Aveamantium wrote:Ahhh yes, forgot about 4125 TCP! You need that one for Remote Desktop to work! :) Yeah, I have just never felt all that comfortable with port 80 making it to my server. Hope it works for you (just using SSL).


It should. Port 80 is optional, or so I've heard. Just adds convenience . . . and attendant risk, as you correctly point out. Certainly worth a shot removing 80 and seeing how it works. I appreciate the tip.
#16980 by astehn
Sun Aug 23, 2009 9:59 am
Hello everyone. I'm pretty new to both Ooma and Windows Home Server, but I have some experience setting up small networks. I've followed this thread closely (as well as others on the forum) and am very close to having a perfectly working setup. I'm just hoping someone can help me make the last crucial step to make my WHS remotely accessible via its Windows Domain Name.

My network looks like this: 1) Cable Modem --> 2) Ooma --> 3) Trendnet Router --> 4) WHS. My Ooma has the default IP: 172.27.35.1 and it is configured to give out a single IP address to my router: 172.27.35.10 This address is also entered as the DMZ address. In turn, ports 80, 443, and 4125 are forwarded on my Trendnet router so that they go to my WHS, which is always at 192.168.10.100

Right now, I can access my Windows Home Server remotely via https (from someone else's network but not my own given the NAT loopback issue that's been documented on the forums), but only if I point my browser directly to the IP address assigned by my ISP. So the only thing that does NOT work is my ability to access my home server via the domain address provided by Windows Live Custom Domains (e.g. myhomeserver.homeserver.net). My home server config page reports that remote access is available (which I've confirmed by accessing it directly using the IP address dynamically assigned by my ISP), but it lists my personal domain status as "Not Working."

I'm not familiar enough with how the WHS updates my personalized domain name with the current public IP address dynamically assigned by my ISP, but I suspect that what's happening is that the WHS is simply looking at the WAN address of my Trendnet router (172.27.35.10), which is obviously not my public IP address.

Of course, I could be completely wrong about why it's not working. I'm just hoping that someone out there has configured a similar setup successfully. Generally, it seems that people solve this problem by putting the Ooma behind their router, but 1) I don't have any free LAN ports, and 2) my router doesn't do Qos, so I need to keep my Ooma before my router. Can anyone help? Thanks!
#16983 by dtalwar
Sun Aug 23, 2009 10:23 am
If you go into the console on WHS, then Settings -> Remote Access -> Domain Name, what is the status? Does it show the domain name? Click on the Details button and then Refresh, and see what messages you get.

Who is online

Users browsing this forum: No registered users and 11 guests