Got something else to discuss that is not covered by the previous forums? Post it here!
#85738 by sites
Tue Aug 16, 2011 10:30 am
The contacts on the base (charger) don't stay in contact with the contacts of the handset. The contacts in the base themselves do not rise after being depressed by the weight of the handset. This has been a problem since the first week I had the equipment. I use a toothpick to gently slide these contacts back into their correct position, and that works as long as I gently rest the handset on the base. Some kind of mechanical failure is preventing the contacts from returning to their proper position. I don't hear anything loose in the base when i pick it up and move it around. I have never misused or abused my Telo equipment and followed exact instructions for proper use. Just now, my phone battery died when it was fully charged this morning. The discharge took place over the last 2 hours with me only using the phone for a few short conversations. I've seen threads in the forum blaming this on firmware issues, but I'm not buying it. These handsets are junk.

OOMA NEEDS TO RECALL THESE THINGS AND ISSUE NEW & IMPROVED HANDSETS AND BASES.

I'm not happy with this.
#85971 by sites
Thu Aug 18, 2011 3:27 am
Go ahead and continue to stick your head in the sand, Ooma. I hope it's not a sales-weasel running the circus over there. I'm in the last quarter of my first contract with you, and if I wind up having to fork out $100-$200 at the end of the year just to have equipment that works the way it was advertised I'll take the plunge in to Asterisk and find a better VoIP solution.
#85992 by EricJRW
Thu Aug 18, 2011 7:37 am
Have you called support? If you are under warranty, you may qualify for a replacement. If you wait for your contract to be I up, I suspect your warranty will be up too.

Who is online

Users browsing this forum: No registered users and 13 guests