Got something else to discuss that is not covered by the previous forums? Post it here!
#79307 by gblanston
Thu Apr 14, 2011 8:32 am
Is there a tutorial for this somewhere?

I have placed my network router behind the Ooma device, as suggested. The call quality is certainly improved. So currently I'm set up with cable modem->Ooma->D-Link router.

Previously, I had a music server on one of my PCs (network address 192.168.x.105). I used the router to forward incoming traffic marked port yyyy to go to this PC. It worked great. Using whatismyipaddress.com, I simply told my Android phone to go to that IP address, xx.xxx.xxx.xx:yyyy. When the Ooma device was behind the router, this also worked just fine.

Having placed the router behind the Ooma device, this no longer works. Do I need to tell my smart phone to find the music server by going to the Ooma device address, vs my IP address for the home network? Set up the Ooma device as a pure pass-through, with no dynamic addressing enabled, or what? I'm sure this comes up time and again, but I don't see a walkthrough for it anywhere.

Any help would be greatly appreciated.
#79309 by murphy
Thu Apr 14, 2011 8:50 am
Go into the setup page inside of the ooma box. http://setup.ooma.com or http://172.27.35.1 if you are using OpenDNS.
On the Network page set the starting and ending DHCP addresses to 172.27.35.2
On the Advanced page create a port forwarding rule for your special port to forward to 172.27.35.2.
Power cycle the router so it gets a new IP address. Log into the router and verify that it got 172.27.35.2.

You should now be able to connect to your music server from the outside world.
You can not test it from inside of your network because ooma doesn't support loopback.

Your ISP may frown on you running a server on a residential network address.
Last edited by murphy on Fri Apr 15, 2011 2:10 am, edited 1 time in total.
#79311 by lbmofo
Thu Apr 14, 2011 9:03 am
murphy wrote:Your ISP may frown on you running a server on a residential network address.

Does this mean that my cable internet provider doesn't like me watching what's on my DVR/live TV through sling adapter? :)
#79353 by gblanston
Thu Apr 14, 2011 9:48 pm
murphy wrote:Your ISP may frown on you running a server on a residential network address.


Its for personal use only. Lets me access all of my music without needing a mythical 120gb smartphone.


Thanks, that did the trick
#79485 by nn5i
Sat Apr 16, 2011 7:58 am
murphy wrote:Your ISP may frown on [your] running a server on a residential network address.


ISP don't 'low no servers runnin' 'round here.
ISP don't 'low no servers runnin' 'round here.
We don't care what ISP don't 'low,
We run our servers anyhow.
ISP don't 'low no servers runnin' 'round here.


(Apologies to the Limeliters, owners of the song "Mama don't 'Low")
Edit: though the Limeliters recorded a version of this song, further research shows that actually it's an American folk song, author unknown; and the Limeliters changed the words.
#79820 by Calis
Tue Apr 19, 2011 9:46 pm
Murphy,
I have been reading your instructions in several threads over the last several days. I have re-read them numerous times. I am going to post screen shots so you can see what I have done.

http://i.imgur.com/TFkpp.png

http://i.imgur.com/8VmSU.png

I am testing this via my Android phone *not* connected to my local network...cell phone data network only. I cannot get connected. I have tried various setups, but currently I have the Ooma telo system doing my PPPoE with the username and password, and the router simply has these:

WAN Settings
Attain IP Protocol Dynamic IP Address
IP address 172.27.35.2
Subnet Mask 255.255.255.0
Default Gateway 172.27.35.1

Primary DNS 172.27.35.1
LAN Settings
IP address 192.168.0.1
Subnet Mask 255.255.255.0
DHCP Server Enabled

I am only home for another day, and have been staying 2000 miles away for work and would really like access to my system while away. It all worked great until the telo crashed one day and the tech support people insisted that I put the telo ahead of my router :( Please, please tell me what I've done wrong, it will be two months before I get another shot at it. Thanks.
#79830 by murphy
Wed Apr 20, 2011 2:31 am
Clear out the DMZ entry in the Ooma. Forwarding rules don't work for an IP address that is in the DMZ.

In your router you have two different RDC ports forwarded to the same IP address.
I'm not sure what you are trying to do since RDC only uses one port. Is the second entry supposed to be the IP address of a second computer?

If 3390 is supposed to be a different computer, you have to edit the registry to change the receiving port number.

Make sure that the firewall on the target computer(s) have the ports open for Remote Desktop. If you are using 3390, that requires a new firewall rule to allow it to work.

I was not aware there was an Android RDC client available, I will have to do a search on my phone.

If you can't get it working in time, put the Ooma behind your router. I have been running a hub and a Telo behind my router for close to two years.

If you want an outside test send me your external IP address via my email link under my avatar and I'll try it from a Windows 7 computer. Do not give me anything other than the IP address. I do remote support for my two brothers all of the time.
#79841 by Calis
Wed Apr 20, 2011 5:10 am
Yes, I have 3389 and 3390 both set up in the telo and in the router, but it is out of desperation of forgetting which of those two ports were RDC..my old router required at least 2 ports open for forwarding and I have done that out of habit. I have just removed the extra port, cleared the DMZ and cycled the power on the telo and the router. I still am having no success. As for putting the telo back behind the router, I'm all for it except I'm a bit nervous about it. If it crashes again and is unable to update, then my family will be without telephone service until I get home again.

The RDC client I am using is called Remote RDP Enterprise. I have used it in the past with great success, and it still does fine internally also. http://www.appbrain.com/app/remote-rdp- ... ersmanager

I can shoot you my IP if you want to verify, but not in a public forum :)

Thanks for trying to help. I'm starting to think that my setup just doesn't want to cooperate.
#79842 by lbmofo
Wed Apr 20, 2011 5:15 am
Calis, murphy wanted you to email him with the IP. Click on the envelope under murphy's avatar.

Also, when you do testing at home, make sure your wifi on your phone is not turned on.
#79843 by Calis
Wed Apr 20, 2011 5:24 am
lbmofo,
Done, I didn't think he had an envelope to mail it to :) As for wifi, I made sure it was off as I know that won't work. Thanks.

Calis

Who is online

Users browsing this forum: Google [Bot] and 12 guests