Telo length of service

Something on your mind? Want to give us feedback on something in particular or everything in general? Tell us how we are doing!
EX Bell
Posts: 401
Joined: Fri Jan 20, 2012 10:42 pm
Location: Toronto, Ontario

Telo length of service

Post by EX Bell » Mon Mar 19, 2012 8:00 pm

I've read plenty of posts here about user's Telos failing anywhere from 2 months to 2 years, but I don't see many posts from those that have not had hardware issues and are enjoying consistent results. So what about it? Post your positive results.

I'm strictly looking for results from Telo owners. I also notice that there is a difference between my Telo (purchases January of this year) and the older Telos. Not just the fact that the older models had a Wall port (which mine does not), but the volume, brightness and page buttons used to be on the left of the touch panel, whereas they are along the top of mine. Is there a correlation between these different models and failures?

If you feel like responding, please record the following in your post.

1. Age of Telo
2. Does your Telo have a Phone port and a Wall port (Yes or No) ?
3. If you have a Wall port on your Telo, do you utilize it (Yes or No) ?
4. Did your power supply require replacement (Yes or No) ?
5. Is your Telo Phone port connected to house wiring (Yes or No) ?
6. Is your Telo power plugged into a surge protector (Yes or No) ?
7. Is your Telo power plugged into a UPS (Yes or No) ?
8. Do you use the WiFi adapter (Yes or No) ?
9. Do you use the Bluetooth adapter (Yes or No) ?
10. Are there strong magnetic fields near your Telo such as a CRT Monitor, an induction charger such as Powermat, or large speaker magnets (Yes or No) ?
Last edited by EX Bell on Wed Mar 21, 2012 3:39 am, edited 1 time in total.
Customer Since: 1/17/12
Service: Premier 1/30/2012
BELL Canada Port: 1/30/12 - 2/13/12
TekSavvy via BELL FTTN: 25 Mbps/10 Mbps
Setup: Sagemcom 2864 > Cisco E2000 > Time Capsule v1 > Telo
Handsets: Panasonic KX-TG6655S DECT 6.0

User avatar
lbmofo
Posts: 9337
Joined: Sun Mar 14, 2010 7:37 pm
Location: Greater Seattle
Contact:

Re: Telo length of service

Post by lbmofo » Mon Mar 19, 2012 10:18 pm

1. Age of Telo 10 months
2. Does your Telo have a Phone port and a Wall port (Yes or No) ? No
3. If you have a Wall port on your Telo, do you utilize it (Yes or No) ?
4. Are the volume, brightness and page buttons on the top (Yes or No) ? Yes
5. Did your power supply require replacement (Yes or No) ? No
6. Is your Telo Phone port connected to house wiring (Yes or No) ? No
7. Is your Telo power plugged into a surge protector (Yes or No) ? Yes
8. Is your Telo power plugged into a UPS (Yes or No) ? No
9. Do you use the WiFi adapter (Yes or No) ? Yes
10. Do you use the Bluetooth adapter (Yes or No) ? Yes
11. Are there strong magnetic fields near your Telo such as a CRT Monitor, an induction charger such as Powermat, or large speaker magnets (Yes or No) ? No

My Hub is 2 years (+ 1 week) old though. No issues.

I maybe overdoing it but my Hub has been on a cooling pad since end of 2010:
Image
Pretty cool heh?

Image
Customer Since: 3/13/10
Hardware: Telo & Hub
Service: Premier 12/06/10
Verizon Port: 3/15/10 - 4/02/10
Internet: 100 Mbps/10 Mbps
Setup: SB6141/R6700/Ooma
MainStreetSHARES Ebates: get Ca$h Back when you shop online!!

Image

2spirit
Posts: 153
Joined: Wed Dec 16, 2009 8:28 am
Location: Maryland

Re: Telo length of service

Post by 2spirit » Tue Mar 20, 2012 3:37 am

1. Age of Telo 2 years + 3 months
2. Does your Telo have a Phone port and a Wall port (Yes or No) ? Yes
3. If you have a Wall port on your Telo, do you utilize it (Yes or No) ?No
4. Are the volume, brightness and page buttons on the top (Yes or No) ?Yes
5. Did your power supply require replacement (Yes or No) ?No
6. Is your Telo Phone port connected to house wiring (Yes or No) ?Yes
7. Is your Telo power plugged into a surge protector (Yes or No) ?Yes
8. Is your Telo power plugged into a UPS (Yes or No) ?No
9. Do you use the WiFi adapter (Yes or No) ? No
10. Do you use the Bluetooth adapter (Yes or No) ? Yes
11. Are there strong magnetic fields near your Telo such as a CRT Monitor, an induction charger such as Powermat, or large speaker magnets (Yes or No) ?[/quote] No

I've had great service and no hardware problems. (Typing with one hand . . . and knocking on wood with the other!)
Telo w/ 2 Ooma Handsets
Annual Premier Subscriber

dsinternet
Posts: 852
Joined: Fri Nov 20, 2009 8:32 pm
Location: Minnesota

Re: Telo length of service

Post by dsinternet » Tue Mar 20, 2012 4:22 am

1. Age of Telo - 2 years 4 months
2. Does your Telo have a Phone port and a Wall port (Yes or No) ? Yes
3. If you have a Wall port on your Telo, do you utilize it (Yes or No) ? No
4. Are the volume, brightness and page buttons on the top (Yes or No) ? Yes
5. Did your power supply require replacement (Yes or No) ? No
6. Is your Telo Phone port connected to house wiring (Yes or No) ? Yes
7. Is your Telo power plugged into a surge protector (Yes or No) ? Yes
8. Is your Telo power plugged into a UPS (Yes or No) ? No
9. Do you use the WiFi adapter (Yes or No) ? Yes
10. Do you use the Bluetooth adapter (Yes or No) ? No
11. Are there strong magnetic fields near your Telo such as a CRT Monitor, an induction charger such as Powermat, or large speaker magnets (Yes or No) ? No
I use to have it hooked up an UPS, but don't anymore since I got the wireless.

Cyberchat
Posts: 113
Joined: Wed Mar 23, 2011 2:01 pm

Re: Telo length of service

Post by Cyberchat » Tue Mar 20, 2012 6:28 am

1. Age of Telo ? 3.5 months (replaced in 12/2011 after 18 months)
2. Does your Telo have a Phone port and a Wall port (Yes or No) ? Yes
3. If you have a Wall port on your Telo, do you utilize it (Yes or No) ? Yes I have the port, it is not utilized
4. Are the volume, brightness and page buttons on the top (Yes or No) ? Yes
5. Did your power supply require replacement (Yes or No) ? No
6. Is your Telo Phone port connected to house wiring (Yes or No) ? Yes
7. Is your Telo power plugged into a surge protector (Yes or No) ? Not currently but it was for my first Telo
8. Is your Telo power plugged into a UPS (Yes or No) ? Not currently but it was for my first Telo
9. Do you use the WiFi adapter (Yes or No) ? No
10. Do you use the Bluetooth adapter (Yes or No) ? No
11. Are there strong magnetic fields near your Telo such as a CRT Monitor, an induction charger such as Powermat, or large speaker magnets (Yes or No) ? No
First year: Modem-->OomaTelo-->Router
Now: Modem-->Router-->OomaTelo
Ooma Premier, two phone numbers
Ooma Handset
AT&T DECT-6.0 two-line base with four remotes & headset

WJBertrand
Posts: 123
Joined: Mon Aug 15, 2011 8:53 pm
Location: Ventura, CA

Re: Telo length of service

Post by WJBertrand » Tue Mar 20, 2012 6:37 am

1. Age of Telo 7 months
2. Does your Telo have a Phone port and a Wall port (Yes or No) ? Yes
3. If you have a Wall port on your Telo, do you utilize it (Yes or No) ?No
4. Are the volume, brightness and page buttons on the top (Yes or No) ?Yes
5. Did your power supply require replacement (Yes or No) ?No
6. Is your Telo Phone port connected to house wiring (Yes or No) ?Yes
7. Is your Telo power plugged into a surge protector (Yes or No) ?Yes
8. Is your Telo power plugged into a UPS (Yes or No) ?Yes
9. Do you use the WiFi adapter (Yes or No) ?No
10. Do you use the Bluetooth adapter (Yes or No) ?No
11. Are there strong electro-magnetic fields near your Telo such as a CRT Monitor, an induction charger such as Powermat, or large speaker magnets (Yes or No) ?No, but my WiFi router is close by
WJBertrand
Ventura, CA

WayneDsr
Posts: 3790
Joined: Wed Feb 04, 2009 6:28 pm
Location: Northern Indiana

Re: Telo length of service

Post by WayneDsr » Tue Mar 20, 2012 7:31 am

1. Age of Telo 2 YEARS
2. Does your Telo have a Phone port and a Wall port (Yes or No) ? YES
3. If you have a Wall port on your Telo, do you utilize it (Yes or No) ? NO
4. Are the volume, brightness and page buttons on the top (Yes or No) ? YES
5. Did your power supply require replacement (Yes or No) ? YES
6. Is your Telo Phone port connected to house wiring (Yes or No) ? NO
7. Is your Telo power plugged into a surge protector (Yes or No) ? YES
8. Is your Telo power plugged into a UPS (Yes or No) ? YES
9. Do you use the WiFi adapter (Yes or No) ? YES
10. Do you use the Bluetooth adapter (Yes or No) ? NO
11. Are there strong magnetic fields near your Telo such as a CRT Monitor, an induction charger such as Powermat, or large speaker magnets (Yes or No) ? NO
No issues with the Telo at all.

I also have an Ooma Hub, brand new in 2009, never replaced and used daily.

Wayne
ooma customer since January 2009
ooma hardware: core (hub/scout) and Telo
Lifetime Premier Member

jblock312
Posts: 36
Joined: Thu Dec 30, 2010 5:17 am

Re: Telo length of service

Post by jblock312 » Tue Mar 20, 2012 7:40 am

1. Age of Telo 1 year, 4 months
2. Does your Telo have a Phone port and a Wall port Yes
3. If you have a Wall port on your Telo, do you utilize it No
4. Are the volume, brightness and page buttons on the top Yes
5. Did your power supply require replacement No
6. Is your Telo Phone port connected to house wiring Yes
7. Is your Telo power plugged into a surge protector Yes
8. Is your Telo power plugged into a UPS No
9. Do you use the WiFi adapter No
10. Do you use the Bluetooth adapter No
11. Are there strong magnetic fields near your Telo such as a CRT Monitor, an induction charger such as Powermat, or large speaker magnets No

kdmc69
Posts: 502
Joined: Wed Aug 27, 2008 1:15 pm
Location: Raleigh, NC

Re: Telo length of service

Post by kdmc69 » Tue Mar 20, 2012 8:23 am

EX Bell wrote:I've read plenty of posts here about user's Telos failing anywhere from 2 months to 2 years, but I don't see many posts from those that have not had hardware issues and are enjoying consistent results. So what about it? Post your positive results.

I'm strictly looking for results from Telo owners. I also notice that there is a difference between my Telo (purchases January of this year) and the older Telos. Not just the fact that the older models had a Wall port (which mine does not), but the volume, brightness and page buttons used to be on the left of the touch panel, whereas they are along the top of mine. Is there a correlation between these different models and failures?

If you feel like responding, please record the following in your post.

1. Age of Telo 2yrs + 4 mos.
2. Does your Telo have a Phone port and a Wall port (Yes or No) ? Yes
3. If you have a Wall port on your Telo, do you utilize it (Yes or No) ? No
4. Are the volume, brightness and page buttons on the top (Yes or No) ? Yes
5. Did your power supply require replacement (Yes or No) ? No
6. Is your Telo Phone port connected to house wiring (Yes or No) ? Yes
7. Is your Telo power plugged into a surge protector (Yes or No) ? No
8. Is your Telo power plugged into a UPS (Yes or No) ? Yes
9. Do you use the WiFi adapter (Yes or No) ? No
10. Do you use the Bluetooth adapter (Yes or No) ? No
11. Are there strong magnetic fields near your Telo such as a CRT Monitor, an induction charger such as Powermat, or large speaker magnets (Yes or No) ? No
Ooma Customer Since: August 2008
Ooma Equipment: 2 Telos + 2 HD2 Handsets
Ooma Service: Premier
Amped AC 1750 Router
TWC ->Router -> Telo1
TWC ->Router -> Telo2

EX Bell
Posts: 401
Joined: Fri Jan 20, 2012 10:42 pm
Location: Toronto, Ontario

Re: Telo length of service

Post by EX Bell » Tue Mar 20, 2012 5:05 pm

Thanks for the replies so far. Few of them made me :)
Good to see so far that there several positive experiences as I suspected, mine included of course, but I'm early in the life cycle of my Telo. Please keep the responses coming.
Customer Since: 1/17/12
Service: Premier 1/30/2012
BELL Canada Port: 1/30/12 - 2/13/12
TekSavvy via BELL FTTN: 25 Mbps/10 Mbps
Setup: Sagemcom 2864 > Cisco E2000 > Time Capsule v1 > Telo
Handsets: Panasonic KX-TG6655S DECT 6.0

Post Reply