Caller ID not working

Something on your mind? Want to give us feedback on something in particular or everything in general? Tell us how we are doing!
Post Reply
tadpolesuv
Posts: 11
Joined: Fri Nov 27, 2009 11:26 am

Caller ID not working

Post by tadpolesuv » Thu Dec 02, 2010 1:50 pm

I have been having trouble with my outbound caller ID for the past 3 months. I have been an OOMA customer for a year now. My phone number does not show up when calling AT&T phone numbers. Something had to change because it worked before 3 months ago. This has been a real problem because several of my friends have a privacy service and when you number does not show up it takes you through a long process of telling them who you are before they pick up. Very frustating. I have called support at lest 10 times. Thye keep telling me it is an AT&T problem. Maybe it is but how am I supposed to fix that. I would at least expect OOMA to help me get the problem resolved with AT&T but they have been very little help. I am to the point where I am considering moving to another service. I am even a premier customer but still get the same run around.
:cry:

User avatar
Leeway
Posts: 933
Joined: Tue Apr 28, 2009 6:50 pm
Location: North of Milwaukee WI

Re: Caller ID not working

Post by Leeway » Thu Dec 02, 2010 3:10 pm

I have a lady friend in a club and we have the exact problem. I tried and tried to call her, and all I ever got was the privacy recording that you've referred to.

I finally told her that I was done trying because from what I read on Google it is indeed AT&T that cannot seem to get it ironed out. They've called AT&T several times and finally they asked to have the whole privacy thing removed from their account. They were also paying extra for the stupid service.

Donna

User avatar
RickO
Posts: 143
Joined: Mon Jan 26, 2009 7:19 pm
Location: Raleigh, NC

Re: Caller ID not working

Post by RickO » Thu Dec 02, 2010 5:10 pm

tadpolesuv wrote:I have been having trouble with my outbound caller ID for the past 3 months. I have been an OOMA customer for a year now. My phone number does not show up when calling AT&T phone numbers. Something had to change because it worked before 3 months ago. This has been a real problem because several of my friends have a privacy service and when you number does not show up it takes you through a long process of telling them who you are before they pick up. Very frustating. I have called support at lest 10 times. Thye keep telling me it is an AT&T problem. Maybe it is but how am I supposed to fix that. I would at least expect OOMA to help me get the problem resolved with AT&T but they have been very little help. I am to the point where I am considering moving to another service. I am even a premier customer but still get the same run around.
:cry:
I've had the same issue since January '09 with my Hub number & September '09 with the Telo. I wish I could believe there'll be a fix, but I think it doubtful. My outbound CID displays either "Private", (Hub), or "Out of Area", (Telo). It may work correctly for a day to a month, but it always goes back. I've probably had a total of three months out of the last year & 10 months where it has worked correctly. Ooma-to-Ooma calls are fine. It only acts up when I call another landline. If folks don't recognize the number, they usually don't answer.
Ooma customer service has been wonderful, but I think that this one has them stumped.

tadpolesuv
Posts: 11
Joined: Fri Nov 27, 2009 11:26 am

Re: Caller ID not working

Post by tadpolesuv » Sun Dec 12, 2010 6:09 am

Customer service has tried to fix my caller I'd but have not been successful either. It is really a problem for me since my girlfriend has privacy mgr and every time I call her I have to go through the unknown called dance and that gets old really fast. There has to be someone there who has an idea.

User avatar
nn5i
Posts: 554
Joined: Fri Jun 11, 2010 2:02 pm
Location: Portland, OR

Re: Caller ID not working

Post by nn5i » Sun Dec 12, 2010 7:49 pm

RickO wrote:Ooma customer service has been wonderful
Does that mean they make soothing noises, or does it mean the actually help?

User avatar
RickO
Posts: 143
Joined: Mon Jan 26, 2009 7:19 pm
Location: Raleigh, NC

Re: Caller ID not working

Post by RickO » Sun Dec 12, 2010 8:23 pm

There have been some very caring people that have worked with me on this problem, most notably, Raz Ramlogan. Unfortunately, she's no longer with Ooma. She actually called me on her last day with Ooma, to check to see if the outbound CID issue had been resolved.

Post Reply