Some Telo handsets cannot answer

Having trouble placing or receiving calls or using your voicemail system on Ooma Telo VoIP Phones? Post your questions here.
Post Reply
gglockner
Posts: 4
Joined: Mon Dec 28, 2009 11:46 am

Some Telo handsets cannot answer

Post by gglockner » Thu Jun 10, 2010 8:46 am

I have noticed a recent problem with one of our Telo handsets. When it rings, I am unable to answer the call. I can answer the call from another handset. Afterwards, the caller ID information is stuck on the display of the non-functioning handset.

I can place a call from this handset.

I have tried the obvious things of rebooting the handset and trying to update the handset software. And the handset is fully charged and sitting in its cradle.

The handset is running version 37410.

ntoy

Re: Some Telo handsets cannot answer

Post by ntoy » Thu Jun 10, 2010 1:05 pm

Hello,

Also tried removing the battery for a few minutes & factory reset on the handset to register again?

If still no go, please contact our support folks to RMA the handset.

Post Reply