Caller ID Issues

Having trouble placing or receiving calls or using your voicemail system on Ooma Telo VoIP Phones? Post your questions here.
Post Reply
Stackowax
Posts: 24
Joined: Sun Sep 13, 2009 7:22 pm

Caller ID Issues

Post by Stackowax » Mon Oct 26, 2009 5:31 pm

I have a Telo and my number has been ported for several weeks now. I have the premier package. I'm using a dry loop DSL connection.

With my prior land-line service I generally saw the phone number and name of the incoming caller (unless they blocked it). Now, almost always, all I see is the phone number. Only occasionally do I see a name.

Any thoughts on this?

User avatar
ajw522
Posts: 247
Joined: Sun Oct 04, 2009 11:52 am
Location: Irvine, CA

Re: Caller ID Issues

Post by ajw522 » Mon Oct 26, 2009 9:29 pm

Nvm
Last edited by ajw522 on Wed Oct 28, 2009 2:11 pm, edited 1 time in total.
Customer since August 2009
Hardware: Core Telo w/ HD2 Handset;2 ooma Hubs
Lifetime Premier Subscription
iPhone 7 Plus w/Ooma Mobile App
Internet: AT&T U-Verse 50Mbps

Groundhound
Posts: 2711
Joined: Sat May 23, 2009 9:28 am
Location: Atlanta, GA

Re: Caller ID Issues

Post by Groundhound » Tue Oct 27, 2009 3:36 am

Stackowax wrote:I have a Telo and my number has been ported for several weeks now. I have the premier package. I'm using a dry loop DSL connection.

With my prior land-line service I generally saw the phone number and name of the incoming caller (unless they blocked it). Now, almost always, all I see is the phone number. Only occasionally do I see a name.
Since you are a Premier subscriber, you should be receiving CallerID Name service. Unfortunately AFAIK there is nothing from the user end you can do to fix the problem as you've stated it, and a call to tech support will be necessary. When doing so you should log when you make the call and what the tech tells you, and the ticket number.

Post Reply