This forum includes tips for maintaining the best audio quality possible with the Ooma System. If your Ooma system is having issues with dropped calls, static audio or echo, look here for assistance.
#54593 by hari
Sun May 02, 2010 5:22 pm
I currently have internet through UVerse and my internet speed tests very close to the promised speed of 3mbps download and 1mpbs upload. The UVerse RG (residential gateway) is a combined modem and router and since it didn't have support for static DHCP, I have been running a tomato router behind it and all my wired and wireless devices connect through it (only my tomato router connects directly to RG in the DMZPlus mode, which assigns the public IP directly to the tomato router). I currently have my ooma device also connected to tomato router with a QoS setting to give highest priority for all traffic coming from ooma's WAN side MAC id. The current status is that the sound quality is mostly good, but occasionally I get static for up to a second at a time and I think only this happens only when there are downloads or video streams going on.

I would like to fix this problem and am looking at two possibilities:
- Since recent RG firmware update seems to add support for static DHCP, I could simplfy the setup and run tomato router in client mode. I would still like to keep the tomato router mainly for the reason that this is also my main SSH server through which I do SSH port-forwarding to my other devices. This means, I could connect ooma directly to RG, but would still need to connect the rest of the wired and wireless devices through tomato router. However, I suspect that this may not improve the situation much, as ooma device is still not getting a chance to control QoS.
- The second options is very similar to the above, except that ooma will sit between the RG and tomato router so that it will get an opportunity to do QoS. However, I am worried about the added complexity. Will this reduce the throughput or increase the latency of my rest of the devices? Will I be able to do the port-forwarding just fine from RG, though the devices are behind ooma? In other words, can I run all devices in the same subnet?

Is there a different configuration that will work better? I have done searches for uverse and qos and didn't find any previous forum posts on this topic. I would appreciate any help on this.

On an alternative note, is it possible that I am not doing QoS setting in tomato correctly. I am now prioritizing based on the MAC, this way (macid partially masked for privacy)

From 00:18:61:xx:xx:xx
TCP/UDP Highest OOMA traffic

In more details:

Src Mac: 00:18:61:xx:xx:xx
Class: Highest
TCP/UDP
Any Port
IPP2P (disabled)
Layer 7 (disabled)
No range set for "KB transferred"

Should I use a different rule instead of this? I did make sure to use the right MAC (the one the router identifies, instead of what is marked underneath the device). I also used the right outbound and inbound limits (matching my speed limits) and allocate 80% to highest category.

PS: I just realized the other reason I would want tomato router in DMZPlus, right behind the uverse RG, viz., DDNS. Currently, since tomato router gets assigned the public IP, Dynamic DNS works beautifully without me having to run a service on any one of my PC's, and I depend on this when I have to ssh login to my devices from outside my network. This probably means, I should concentrate on getting QoS working with tomato rather than keeping Ooma between the two routers.
#54701 by hari
Mon May 03, 2010 7:50 pm
I did some more research and it appears that running ooma behind my tomato router is the best option for now, so would like to seek help to improve QoS settings. I have run several [url=voip tests]http://myspeed.visualware.com/voip/[/url] with and without any video streams going on. When there is no other internet activity, the report looks somewhat like this:

VoIP test statistics
--------------------
Jitter: you --> server: 0.2 ms
Jitter: server --> you: 3.8 ms
Packet loss: you --> server: 0.0 %
Packet loss: server --> you: 0.0 %
Packet discards: 0.0 %
Packets out of order: 0.0 %
Estimated MOS score: 4.0


But when I start video streams and run the test again, I get something like this:

VoIP test statistics
--------------------
Jitter: you --> server: 0.8 ms
Jitter: server --> you: 49.1 ms
Packet loss: you --> server: 0.0 %
Packet loss: server --> you: 1.2 %
Packet discards: 0.0 %
Packets out of order: 0.0 %
Estimated MOS score: 3.4


If at the same time, I make a call, the incoming voice quality is significantly worse as I hear a short hiss/static almost every couple of seconds. Since nobody ever complained on the other side about bad voice quality (even when I am hearing static), I am assuming that outgoing voice quality is fine, and this is probably why the jitter for "server --> you" goes that bad, but "you --> server" part remains OK.

I have tried to limit the inbound traffic in tomato so that a significant chunk of bandwidth is always left for voice, but this doesn't improve the situation. I also tried connecting ooma directly to my RG, hoping that it would make use of the reserved bandwidth better with no improvement. In fact, I don't think tomato is even able to limit the download, so the setting there doesn't really matter.

The other thing that I noticed is that it doesn't really take much download activity to make the voice quality go down. I tried limiting the inboud/outbound bandwidth to 768/500 using firefox throttle addon (which is very effective) and still I noticed the static in the calls. What could be causing the jitter to go up even with minimal download/streaming going on? Any experts here to help me out with this issue?
#54731 by Tiger5353
Tue May 04, 2010 12:49 pm
I have heard of this before with slower ISP connections like u-verse the more downloads you do the higher the jitter you will get. I have cox cable and i paid for there slower connection but when i got a telo i had the same problems your having. I did some checking and found server board messages talking about increasing my speed might help so i called cox cable and had them increase my speed from 3 meg per seconds to 12 meg (cost me $15 dollars more a month). My jitter went from 78 to 2 while i was downloading other files and all my problems with static and dropped calls went away.

Here is a quote about jitter and what it is and what causes it.

Jitter when applied to VoIP is a variation in packet transit delay. The causes of jitter are typically queuing, contention and serialization effects on the path through the network. Faster, higher bandwidth networks tend to have less jitter whereas slower networks tend to have more congestion and more jitter.

Here is the site that i got the quote from http://www.whichvoip.com/voip/speed_tes ... ml#Factors

There is some other good info there as well.

I don't know if increasing your bandwidth will help but it did for me.
#54741 by hari
Tue May 04, 2010 1:39 pm
I would be surprised if increasing the bandwidth could fix this problem, as what I found is that even single youtube video could have deteriorating effect, whether I am capping the download speed (using firefox throttle addon) or not. If I have 3mpbs download bandwidth and cap it to under 768kbps, I have so much more left for voip (e.g., the download speed reported by firefox throttle never exceeds 120kb/s). In fact, even if I open a website that is rich with content while talking to someone, I could hear one or two instances of static when the page is loading and then it goes normal. I could probably try stepping up my u-verse service for a month, but I should also make sure I wouldn't loose any promotional pricing in that process (I currently pay $30 for 3mpbs, but they might be charging more right now).
#54767 by Tiger5353
Tue May 04, 2010 6:49 pm
I did the same as you set QoS on the telo to what my uploads and downloads should be set at. It made no difference. Even went as far as buying a new router that supported QoS and plugged the telo into it and then set the router to the correct QoS settings. That didn't do any good either. Finally had cox increase my bandwidth. That did it. I'm not saying that this will do it for you, just telling you what happened to me.

hari wrote:I would be surprised if increasing the bandwidth could fix this problem, as what I found is that even single youtube video could have deteriorating effect, whether I am capping the download speed (using firefox throttle addon) or not. If I have 3mpbs download bandwidth and cap it to under 768kbps, I have so much more left for voip (e.g., the download speed reported by firefox throttle never exceeds 120kb/s). In fact, even if I open a website that is rich with content while talking to someone, I could hear one or two instances of static when the page is loading and then it goes normal. I could probably try stepping up my u-verse service for a month, but I should also make sure I wouldn't loose any promotional pricing in that process (I currently pay $30 for 3mpbs, but they might be charging more right now).
#54770 by hari
Tue May 04, 2010 8:13 pm
Tiger5353, thanks for sharing your experience, I certainly appreciate it. So,do you still use some QoS settings to limit bandwidth? Even with higher bandwidth, you could still end up clogging your network, if that much faster things end up downloading (unless your bandwidth is much higher than what most servers normally dish out). After increasing the bandwidth, did you ever try to download several large files or play several videos and see if it impacts your call quality (e.g., if earlier a single video was enough to cause problem, may be now playing 3 videos could end up causing it)?
#54788 by Leeway
Wed May 05, 2010 4:27 am
I have U-Verse and I have no problems like yours.

I have my RG connected to a Netgear switch to add ports. I have my Telo plugged directly into the RG and my TV's. Other things are using the switch.

I've never bothered with QOS because the RG doesn't deal with it.

I can download torrents, watch recorded video and I've never noticed a glitch.
I have the bottom line U-Verse speed.

Try plugging your Ooma into the RG is my suggestion. Be sure to reboot everything.

Donna
#54796 by Tiger5353
Wed May 05, 2010 6:13 am
Yes i kept the router and have the QoS settings set correctly. And yes i have downloaded large files while talking on the telo. No problems.

hari wrote:So,do you still use some QoS settings to limit bandwidth? Even with higher bandwidth, you could still end up clogging your network, if that much faster things end up downloading (unless your bandwidth is much higher than what most servers normally dish out). After increasing the bandwidth, did you ever try to download several large files or play several videos and see if it impacts your call quality (e.g., if earlier a single video was enough to cause problem, may be now playing 3 videos could end up causing it)?
#54841 by tommies
Wed May 05, 2010 5:22 pm
It seems that your problem is the QoS in tomato. There are several experienced tomato users on this board, and hopefully some will chime in to help.

BTW, I had att dsl with 1.5M down/256k up and having no problem when downloading and/or streaming. Also I have to stress that my att dsl quality was very good (even with its limited bandwidth)
#54845 by hari
Wed May 05, 2010 5:58 pm
May be I should start a new topic just to address the QoS settings. That way I can get better attention from experts who might not want to read this entire thread.

Who is online

Users browsing this forum: No registered users and 6 guests