This forum includes tips for maintaining the best audio quality possible with the Ooma System. If your Ooma system is having issues with dropped calls, static audio or echo, look here for assistance.
#87756 by BJN2
Thu Sep 29, 2011 8:02 am
I'm having the upstream side of conversations break up badly, frequently terminating the call and putting the person I'm talking to into my voice message.

My Ooma Hub has been working for a long time with only occasional echos and minor glitches, but over the last month or so I've had this upstream voice problem get worse and I have to figure it out or get some other phone service. I have ample bandwidth and have run the speed tests I've found researching this forum and my net connection isn't the problem.

My preferred configuration for the Ooma hub has been Ooma>switch>router>modem. I relatively recently upgraded to a new Cisco DOCSIS 3.0 DCP3000 cable modem, which got me a free speed boost for my Comcast service. At the same time I also upgraded to a Linksys E3200 router with wireless. It's possible that my upstream issues started with the new modem and router, but I didn't notice any problems after the hardware upgrade and the problems are inconsistent but seem to have gotten progressively worse.

Based on advice I found in forum threads, I first set the Ooma hub up with a fixed IP address behind the Linksys router. This doesn't appear to have any effect on the problem.

A couple of days ago I called Ooma support. The tech had no information for my router and modem. I used my laptop to access the Ooma hub's setup and set QOS to upstream to 750, downstream to 400, and left the reserved bandwith setting at the default of 130. He asked me if I had set up QOS ports on my router, but at the time I had no idea if the router's configuration had that capability. The hubs QOS setting changes didn't improve call quality and I believe that call quality is worst when I have other upstream traffic going on (sending files via Dropbox, for example).

I found QOS configuration for my E3200 router under the Applications and Gaming tab on the Cisco control panel. I understand that I need to define a new "application" with port ranges, TCP/UDP/or Both, and a priority level, but I have no idea what values to enter here and haven't been able to find hints via forum threads. I thought I'd run this by the forum before I call Ooma support again. I'm attaching a screenshot of the Linksys QOS control panel.

I don't know how to interpret the Ooma setup ports information, but here's what it says minus the MAC addresses (at the moment, the Ooma is between the modem and the router):

HOME Link encap:Ethernet HWaddr xxxxxxxxxxxxx
inet addr:172.27.35.1 Bcast:172.27.35.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:45603 errors:0 dropped:0 overruns:0 frame:0
TX packets:40037 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6478001 (6.1 MiB) TX bytes:6902966 (6.5 MiB)
Interrupt:14
MODEM Link encap:Ethernet HWaddr xxxxxxxxxxxx
inet addr:98.202.207.120 Bcast:255.255.255.255 Mask:255.255.240.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3252110 errors:0 dropped:0 overruns:0 frame:0
TX packets:292909 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:214606631 (204.6 MiB) TX bytes:29289798 (27.9 MiB)
Interrupt:13

Thanks for any help or advice you can offer. My level of network understanding is low, so please dumb it down for me ;-)
Attachments
Cisco QOS.jpg
Cisco control panel for Linksys E3200 router.
Cisco QOS.jpg (116.3 KiB) Viewed 14428 times
#87758 by thunderbird
Thu Sep 29, 2011 8:32 am
BJN2:
Upload Garbled Voice:
First, make sure you are using Built-In MAC address in you Ooma Hub.

Second, with a Modem-Router-Switch-Ooma connection, Ooma suggests that you set your Quality of Service Upstream and Downstream settings to Zero. For some people this doesn't work, so if it doesn't work for you, set your Quality of Service Upstream and Downstream settings to a value higher than the Upload and Download readings as measured by http://www.speedtest.net/ .

If you want to Port Forward Ooma ports, they are listed here https://www.ooma.com/app/support/advance ... vice-ports .
You must reserve an IP address with a permanent lease, in your router, before doing any Port Forwarding, in your router.
Last edited by thunderbird on Fri Sep 30, 2011 3:48 pm, edited 1 time in total.
#87761 by BJN2
Thu Sep 29, 2011 9:23 am
For the Linksys fixed IP configuration I used the Hub's modem port MAC address. It took me a while to figure out that the hub's decal has the Home port MAC address and the difference.

I'll try the zeroed settings. Failing that, I'll try Speedtest values (attached). I don't follow the logic of trying settings above the maximum upload and download rates (which vary every time I test them) but I'll give that a try if zeroing doesn't help.

The port forwarding page is just what I was looking for. I'll spend some time understanding it before I dive into further troubleshooting.

Thanks for your assistance!
Attachments
Speed test 9-20-2011 5-04-19 PM.jpg
Detailed speed test from the other test site link I found here.
Speed test 9-20-2011 5-04-19 PM.jpg (44.19 KiB) Viewed 14420 times
#87763 by thunderbird
Thu Sep 29, 2011 11:21 am
BJN2 wrote:For the Linksys fixed IP configuration I used the Hub's modem port MAC address. It took me a while to figure out that the hub's decal has the Home port MAC address and the difference.

I'll try the zeroed settings. Failing that, I'll try Speedtest values (attached). I don't follow the logic of trying settings above the maximum upload and download rates (which vary every time I test them) but I'll give that a try if zeroing doesn't help.

The port forwarding page is just what I was looking for. I'll spend some time understanding it before I dive into further troubleshooting.

Thanks for your assistance!

Setting the Ooma devices Quality of Service settings to zero, shuts off the Ooma device QoS. The Ooma device's bandwidth sharing isn't need for a Modem-Router-Ooma configuration. But it seems like setting the QoS settings to zero, doesn't always fully shut off the Ooma Device's QoS bandwidth sharing, and sometimes it seems to restrict itself, and then there is garbled voice, etc. happens. So by setting the Ooma device Upstream and Downstream QoS to more than the Upload/Down load speeds provided by the Internet provider, the Ooma device's QoS doesn't try to share bandwidth at all.
Last edited by thunderbird on Thu Sep 29, 2011 11:41 am, edited 1 time in total.
#87805 by FX4
Fri Sep 30, 2011 1:35 pm
I'll read up on the 3200, and give you some guidance. The one thing I'm not clear on is if you shut shaping off on the Ooma hub is if DiffServ is shut off. My ISP respects DiffServ, your ISP may or may not. I'm not entirely certain I agree with Thunderbird about shutting of QoS when you are behind the firewall because when you shape traffic your voice reservation sends out packets at a regular interval. Set it right and jitter is greatly reduced. Set it too high and you get an underflow condition. Set it too low and you get an overflow condition. This is practical theory and I do not fully know how Ooma has implemented shaping on their products. What I do understand is that Ooma shapes to the available upstream bandwidth so it's important that you perform bandwidth test and set your upstream reservation correctly.
#87807 by FX4
Fri Sep 30, 2011 1:57 pm
They made this really easy for you. Have a read at this:
http://homedownloads.cisco.com/download ... 6_WEB2.pdf

Read the section on "How to optimize your router for gaming and voice" It just looks for the MAC address of your device and gives those packets high priority. Set the upstream bandwidth to either auto or actual. That should do it.

Oh one other thing. I would put the Ooma hub directly on one of the router ports unless your switch supports CoS, queueing, and vlans so that you can specifically prioritize traffic on your switch.
Last edited by FX4 on Wed Oct 05, 2011 7:01 am, edited 2 times in total.
#87811 by BJN2
Fri Sep 30, 2011 2:58 pm
I can't thank you enough. I should have "RTFM" - but instead I was relying on the help information in the Cisco control panel which is more cryptic (and I've been climbing the learning curve). I completely missed the drop down selection control that gives me access to Voice Device and the MAC address priority option. I'll work on this over the weekend. I'll go back to the default hub settings and see if just the MAC priority will do the trick.

And thanks for the tip on the switch. I may upgrade it if it's not capable of port prioritization since that would maximize flexibility for the Hub's location on my wired home network. For now, I'll patch to the router and save the switch issue for later.

It's very kind of you to spend the time researching my issue and posting advice. I owe you a beer (or your beverage of choice) at the very least! I'll circle back with my results once I've had time to configure and test.
#87825 by FX4
Fri Sep 30, 2011 6:55 pm
No problem at all. I hope it solves your problem. I am network engineer by profession so it really wasn't much trouble at all.

The thing with a basic switch that does not support QoS and queuing prioritization is that it's buffers are fifo (first in first out) and that can be bad for voice. With a more advanced manageable switch you can set quality of service via queuing and CoS at layer two. So you would put your voice traffic in a low latency or high priority queue that pushes other things like http back in the output queue.
#87972 by FX4
Wed Oct 05, 2011 7:03 am
I did a little checking around this weekend and the series of switches to go with the Linksys /Cisco router has a very nice automatic QoS feature that is plug and play.

Who is online

Users browsing this forum: Majestic-12 [Bot] and 13 guests