This forum includes tips for maintaining the best audio quality possible with the Ooma System. If your Ooma system is having issues with dropped calls, static audio or echo, look here for assistance.
#6076 by scottclark
Tue Apr 07, 2009 9:49 am
My call quality is very poor outbound.

I have been unable to get Ooma to work outside my router, a SMC8004-BCM cable modem provided by Insight Communications. I realize this is ideal for QOS.

But since that won't work, I would like to utilize the excellent built in QOS configurator on my D-Link DIR 655 router to achieve similar goals.

Image

My D Link QOS screen looks like this. Note what you see in "priority #1" is my "attempt" to get Ooma to use it. It has not helped. I have put an arrow to the place where I've attempted to set up ooma.

Image

Help???????
#6100 by thively
Wed Apr 08, 2009 1:06 am
#1 Your rule looks correct except Ooma calls use UDP protocol, not TCP. Set the protocol to UDP, "both", or "any". I set mine to "any" though "both" should work as well.
But set to TCP only is your problem. This alone should do the trick.

However, two other things to look in to if that doesn't help....

#2 there is a discrepency between the automatic measured uplink speed of about 2.4 Mbps vs your speedtest.net results. The QOS may not work right if the setting is higher than actual available bandwidth. You can try disabling the automatic uplink speed and manully set it to what you actually get (or very slightly below) Note that when QOS is enabled it will restrict lower priortity outbound traffic to this setting. So disable QOS to test your speeds or it will affect your test results.
If the automatic seems to be accurate, then go ahead and leave it on.
I know with my Comcast cable Internet this is totally whacked because they allow for temporary bursts if speed which throws off the automatic measurement.
You may need to experiment with this. Admittedly I'm not an expert and don't totally understand the impact if this setting.

#3 dynamic fragmentation. I don't totally understand this feature but I know it causes problems with video streaming with our Roku player. You could experiment with turning this off. I don't know if this will affect anything either way. But we've been recommending to our customers to disable this since it came to our attention that it's adversely affecting performance (I work for Roku.)

I hope some if this helps.

I have the same router and have the rule set up just as you do except as "all" protocols, uplink is 2048 (my sustained up speed limit is just over 2Mbps) and dynamic us off (though the jury is still out in dynamic.)
#6122 by lohertz
Wed Apr 08, 2009 4:23 pm
have the same router.

Make sure that ooma's ip is reserved.

second manually enter the uplink speed anywhere from 90%-80% of speed test.

third select your connection type DSL or cable

You other settings should be fine. use http://www.whichvoip.com to test VoIP connection speeds and VoIP qualities including QOS
Attachments
qos.JPG
qos.JPG (127.24 KiB) Viewed 6623 times
#6127 by scottclark
Wed Apr 08, 2009 5:24 pm
A huge thanks for the terrific responses here. I have tweaked my router settings with high hopes.

lohertz, what is your resulting call quality with 256k upload?
#6129 by lohertz
Wed Apr 08, 2009 6:08 pm
Before I did anything with my router, my wife said there was some dropping out. I checked my QoS using whichvoip tool and it came back like 10%. Switched the QoS engine to the above settings and it is flawless with very good sound quality. (I dont expect my phone to sound like an orchestra or anything.)

Who is online

Users browsing this forum: No registered users and 13 guests