This forum includes tips for maintaining the best audio quality possible with the Ooma System. If your Ooma system is having issues with dropped calls, static audio or echo, look here for assistance.
#75945 by marcaronson408
Thu Feb 24, 2011 8:42 am
epetru wrote: And just to be clear, this ALWAYS happens when you run a speedtest. There is never a time that you run the speedtest and test the voice quality that the voice quality is good. Right?

So if that's the case, the problem is either at the Ooma service, the Ooma box or the cable modem.


When I configure CableModem->OOMAhob->Router, I do not have any problems when running speed test. The problems only happens with CableModem->Router->OOMAhub, which is why I suspect it is an issue with the way the router handles QOS. On the other hand, I read a posting in a Netgear forum where someone asserted that the problem is caused by some cable modems that have large buffers. When bandwidth on the line slows down the modem continues to accept data from the router for some period of time before throttling the router. This results in the router not realizing that it needs to throttle lower priority traffic until it's too late. I don't know if this is true, but it is an interesting theory.

The OOMA hub's QOS implemention would not be impacted by this, because the OOMA hub ensures voice QOS by severely throttling other upload traffic whenever a call is in progress...

Marc
#77052 by marcaronson408
Sat Mar 12, 2011 8:37 am
I have QOS working reliably now with my Netgear WNDR3700 router. I've stress tested and I do not have any problems while simultaneously running crashplan and streaming a hidef Netflix Video. The attached image shows my setup and has a lot of explanations in it.

Please note that for reasons I do not understand, things did not work until I rebooted the machine running crashplan. After that, everything has worked without any problems.

Marc
Attachments
qos.jpg
qos.jpg (219.22 KiB) Viewed 7109 times
#77069 by gail
Sat Mar 12, 2011 2:04 pm
Hi Marc,
I was happy to read that you have fixed your router setup problem (or, found QoS settings which work for your network). Just for the record, I did not elect any bandwidth shaping when I set up my 3700... and that has worked for me so far. I did, as I've already indicated, designate that my ooma Core's Lan port should have highest priority.
Anyway, it is great to know you are up and running with out any voice quality problems.
Gail
Last edited by gail on Sun Mar 13, 2011 1:57 pm, edited 1 time in total.
#77076 by marcaronson408
Sat Mar 12, 2011 3:29 pm
gail wrote:Hi Marc,
Just for the record, I did not elect any bandwidth shaping when I set up my 3700... and that has worked for me so far. I did, as I've already indicated, designate that my ooma Core's Lan port have highest priority.

Hi Gail,

That's interesting. One of the Netgear engineers was the first person to tell me that the uplink bandwidth setting was required for QOS to do any good. I then read several articles that said the same thing. Just out of curiosity, have you check to see if you have any problems when QOS is turned off?

Marc
#77091 by gail
Sat Mar 12, 2011 8:39 pm
Hi Marc,
I decided to skip the band width control setting because I had trouble checking upload bandwidth...it did not seem to work on my router setup page. Because of this I decided to just go with the QoS Priority Rule setting. I figured that I would probably have to contact tech support about my inability to use the upload test - but I never did do that because my ooma calls have been clear and I have not felt the need to tweak my settings.
I have always assumed that I would have some quality issues if my ooma was not protected by its current high priority status, but I have not turned that status off in order to test it. (I seem to always work on these things either very early or very late in the day...not a time when I can easily have someone telephone me to check voice quality.)
Gail

P.S. I should probably add that my setup may not have been put to the test yet...as I generally do not have much other activity on my network when I am on the telephone. When summer is here that will change, and I may find that I have to think about bandwidth shaping.
Attachments
Picture 4.png
Picture 4.png (114.79 KiB) Viewed 7088 times
#77099 by marcaronson408
Sat Mar 12, 2011 10:33 pm
gail wrote:P.S. I should probably add that my setup may not have been put to the test yet...as I generally do not have much other activity on my network when I am on the telephone.

That is probably the reason you are not having problems with voice quality. This QOS article explains it in detail. Here are some of the key paragraphs from that article that are relevant to our discussion:

QoS depends on knowing how much data can be enqueued at any time. This is called your "upstream bandwidth" or "upload bandwidth" allocation, and it is capped by your ISP, usually using a setting in your modem. Unfortunately, modems do not generally report this data directly to the router, so the router has to guess at upstream allocation. Some routers do this well, some do not. Some modems will queue the packets, thereby fooling the router into thinking that the modem can take more than the capped bandwidth

PERFECT QoS: In an ideal setting, 100% of the upstream bandwidth is used, all the time, and any packets are queued locally and discarded (if necesary) before hitting the modem when they reach their TTL (Time To Live, an indication of how long to continue attempting to deliver the packet).

QoS Upstream Too High: If your router thinks it has more upstream bandwidth than it really has, QoS becomes useless, as the router is stuffing more data into the pipe than the pipe can handle. Since the modem itself doesn't know which packets are important, it starts delaying and dropping packets at random, including ones you think are important.

QoS Upstream Too Low: If your router thinks it has less upstream bandwidth than it really has, QoS becomes a limiting factor on your network, since the router is artifically limiting your upstream to some figure below what your connection is actually capable of.

If your AUTO setting on your router does not work well, but your router has a MANUAL setting, here's what you want to do:

1. Go to http://www.dslreports.com/stest on an IDLE connection, with QoS turned completely OFF and nothing else on your network trying to use the Internet at all (or your computer hooked directly to your modem). Run the Speed Test a couple of times, and write down the tested upstream bandwidth. Run this test several times, at different times of day.

2. Enter about 90-95% of the LOWEST number you get on your tests into the "upstream bandwidth" field on your router. At whatever time of day is the worst for your upload bandwidth, start a large upload (start BitTorrent, or a large FTP upload, or whatever), and test the connection using testyourvoip.com or an outbound VoIP call. And adjust this number upward until you start seeing loss on your upload results, then lower the number back down to the highest setting that gives you good results.

One criticism of this approach is that you are artifically limiting your bandwidth to the "lowest common denominator", particlularly on Internet connections that have good upstream bandwidth some of the time, and poor bandwidth at others, since you are telling your router NEVER to use any more than the LEAST of your tested bandwidth. That is absolutely, 100% correct. But if your router cannot get good numbers, then you HAVE to set it manually, and you'll get better useability out of an underused connection that works consistently than a connection that gets overused from time to time. (ie. when available bandwidth drops if you set the number too high, your VoIP line will start acting up again).

#77122 by gail
Sun Mar 13, 2011 6:02 am
Hello again Marc,
I checked out the full article on QoS which you referenced. Very interesting -thank you. It did not leave me feeling uncomfortable with my wait and see approach. (If things go bad I can always put the ooma Core between the modem and router again, if I have to.)
I had one other thought after reading the article, and that is that my new Motorola docsis 3 modem may be a factor here...I wish I knew enough about networking to have a sense of whether or not the modem is what is making a difference for me.
If I do start having problems once my summer guests have arrived with their computers I will be sure to come back to this thread to update my situation.
In the meantime, I hope that all continues to go well for both of us. Gail
#77131 by marcaronson408
Sun Mar 13, 2011 7:45 am
gail wrote: I checked out the full article on QoS which you referenced. Very interesting -thank you. It did not leave me feeling uncomfortable with my wait and see approach.


Couldn't agree more -- as the old expression goes, if it ain't broke, don't fix it. In fact, the very real downside of what I had to do is that I am now capped to 2.4mbps uplink at all times, even though my connection is able to burst as high as 4.1mbps. (I tried higher caps on the uplink, but I immediately started to have voice quality issues.)

My alternative is to revert back to cable_modem->OOMA_HUB->Netgear_Router configuration. The upside is that the OOMA hub only throttles uplink speeds when a call is in progress. The downside is that my recollection is that I had to use a much more severe throttle to make it work. If I get some time I may play with this configuration a bit.

Marc

Who is online

Users browsing this forum: No registered users and 10 guests