This forum includes tips for maintaining the best audio quality possible with the Ooma System. If your Ooma system is having issues with dropped calls, static audio or echo, look here for assistance.
#69231 by lbmofo
Wed Nov 17, 2010 1:48 pm

Having voice quality issues with your Ooma?


First, see if your high speed internet or modem is having issues.

Do an internet speed test to see if you get expected numbers: http://speedtest.net/

For example, if your upload speed is supposed to be 2 Mbps, you shouldn't be getting 300 Kbps. Same thing with download; if you expect 20 Mbps, you shouldn't be getting 700 Kbps.

But speed isn't the only component at play for VoIP to work nicely so....

Also, do a VoIP quality test: http://www.phonepower.com/speedtest

Note: check the "Advanced" tab

murphy wrote:Jitter should be less than 5 ms.
Packet loss should be 0.
Download and upload QOS should be at least 70%.
Maximum TCP delay should be under 100 ms.

If test results look bad, you have a problem with your high speed internet. It may be your modem or internet wiring coming into your home. Note: modem problems could be intermittent so test results may not be consistently bad; also, some folks experience high jitter and TCP delays if subscribed to "lite" versions of internet services.

If you have a cable modem, check some readings:

murphy wrote:Connect to the status web page in your cable modem
http://192.168.100.1
Find the downstream and upstream power in dBmV and the Signal to Noise Ratio (SNR)…
The downstream signal power should be between -10 and +10 dBmV. (Some say between -15 and +15 but I feel that is pushing your luck)
The SNR should be 35 or more.
The upstream power level should be less than 55 dBmV.

If your modem numbers look questionable, do a “restore factory default” on the modem status page & reboot or do a hard reset if the modem has a reset button. Problem may also be too many cable splitters between incoming cable and the modem.

If test results look bad and your ISP can't fix it, swapping your modem to see if things improve might be a good idea.

If you previously had cable phone service and you don't anymore, the cable modem you are using with built in components to provide cable phone service may give you voice quality issues when using Ooma. Change the cable modem into your own and save $7 to $10 a month to boot.

If your internet seems to be okay, make sure to setup your Ooma using Optimum Installation Settings:

If before router: viewtopic.php?t=9536#p66155
If after router: viewtopic.php?t=12403

No matter where your Ooma is placed, if setup.ooma.com "Quality of Service" section has and entry "Reserved Bandwidth for Calls (Kbps):" set it to 215 instead of the default 130.

Note: If you connect your Ooma device behind the router, disable the Ooma upstream QoS by setting "Upstream Internet Speed" to 0 but still use "Use Built in Modem Port MAC address." You might want to setup router QoS if available (by Modem Port MAC address or Ethernet Port #). You may also have to deal with router firewall settings; see link below.

Also check out Vonage > Support Home > How Do I Troubleshoot Audio Issues?

Start from "Reboot all of your devices"; of course, substitute "Vonage device" with "Ooma device."
In the "Other Possible Audio Issues" section, outside of "Do-It-Yourself Home Wiring Guide (Vonage completely botched it up for DSL users)," you can look up more information on distributing Ooma dialtone throughout home: viewtopic.php?t=6853 and https://www.ooma.com/app/support/distrib ... hone-jacks and viewtopic.php?t=13354

For the port fowarding topic, ports used by Ooma: https://www.ooma.com/app/support/advance ... vice-ports




Edits:
  • 01/07/11 fixed broken link to Ooma's dialtone distro page "Distributing Ooma to all telephone jacks"
  • 03/20/12 replaced "www.whichvoip.com/voip/speed_test/ppspeed.html" (they've made it too complicated & bloated now) with "www.phonepower.com/speedtest"
  • 03/20/12 fixed broken link to Ooma's dialtone distro page "Distributing Ooma to all telephone jacks"
  • 03/20/12 added Cyberchat's "How to Distribute VoIP Throughout a Home"
  • 03/20/12 added Optimal Setup for after router
  • 09/06/12 edited outdated "Advanced Connections and Service Ports" link
  • 04/06/13 added suggestion to swap cable modem if no more cable VoIP service and modem is still VoIP capable
Last edited by lbmofo on Sat Apr 06, 2013 11:26 am, edited 11 times in total.
#72442 by lbmofo
Fri Jan 07, 2011 12:30 pm

If everything checks out and even after setting up using
Optimum Installation Settings: viewtopic.php?t=9536#p66155, you still have issues....

Give the following (after router configs) a try and see if they help:


thunderbird wrote:The following setup will correct most of your QoS problems:

General Outline for Setting up Ooma Behind (on Local Area Network side of) Router.

The steps below are just suggestions. Your may choose to use some or all of the Outline steps below, depending on your equipment and network requirements.

1. Temporarily access your Ooma Telo home port by plugging in a patch (network) cable from the Ooma Telo home port to a computer’s network card port. Sometimes you have to restart your computer after installing the patch cable, so that a proper connection occurs.
2. Type http://setup.ooma.com in you browser address window and hit enter. The “Ooma Setup” window opens.
3. Ooma device setup:
a. Enable Ooma device’s built-in MAC address.
b. Assign static IP address (IP number obtained from your router) in the Ooma device.
c. Disable QoS in Ooma device by setting upload/download settings to zero.
4. Verify that your router’s firmware is up to date.
5. Verify that your router provides support for QoS (Quality of Service) VoIP priority. (Some router manufactures use similar but different names for QoS), reference check router manual.
6. Enable router QoS settings as required, reference check router manual.
7. Create in router, router rule(s) to open Ooma ports, (Setup location sometimes found in router gaming menu) reference check router manual.
a. Ooma uses the following application ports for data and voice traffic,
UDP 53, UDP 123, UDP 514, UDP 1194, UDP 3386, UDP 3480, UDP 10000-20000, TCP 53 and TCP 443.
8. –OR—(Step 7 or 9)
9. Place your Ooma device into your router’s DMZ using the static IP address you assigned to your Ooma device, reference check router manual.
10. With Ooma device connected behind (LAN side of) router, don’t use Ooma home port. Use your router ports for other devices on your LAN system.
11. Do a cold boot of router.
12. Do a cold boot of Ooma device after router cold boot has been completed.

Good Luck.

thunderbird wrote:The following setup corrected my dropped call problems, my one way voice conversation problems, plus several other voice quality problems that I was having:

General Outline for Setting up Ooma Behind (on Local Area Network side of) Router.

The steps below are just suggestions. Your may choose to use some or all of the Outline steps below, depending on your equipment and network requirements.

1. Ooma device:
a. Enable Ooma device’s built-in MAC address.
b. Assign static IP address (IP number obtained from your router) in the Ooma device.
c. Disable QoS in Ooma device by setting upload/download settings to zero.
d. To be used for Ooma device behind router only: If after you have configured and tested your setup per this document and you still are experiencing dropped calls, one way voice conversation problems, change your QoS upload/download settings (BOTH) in your Ooma device to at least 2000 kbps above your Internet provider upload/download top speeds, as measured with speedtest.net.
2. Verify that your router’s firmware is up to date.
3. Verify that your router provides support for QoS (Quality of Service) VoIP priority. (Some router manufactures use similar but different names for QoS), reference check router manual.
4. Enable router QoS settings as required, reference check router manual.
5. Place your Ooma device into your router’s DMZ using the static IP address you assigned to your Ooma device, reference check router manual.
6. Create in router, router rule(s) to open Ooma ports, (Setup location sometimes found in router gaming menu) reference check router manual.
a. Ooma uses the following application ports for data and voice traffic,
UDP 53, UDP 123, UDP 514, UDP 1194, UDP 3386, UDP 3480, UDP 10000-20000, TCP 53 and TCP 443.
7. With Ooma device connected behind (LAN side of) router, don’t use Ooma home port. Use your router ports for other devices on your LAN system.
8. Do a cold boot of router.
9. Do a cold boot of Ooma device after router cold boot has been completed.
10. Optional suggestion: For new installation, test Ooma device VoIP phone system for a few days connected to only one wired phone.
Good Luck.
#74551 by highq
Sun Feb 06, 2011 11:33 am
Disconnect everything from your Ooma. Disconnect your computer from the outside.
Run an ethernet nconnection from the Home port on the Telo to the computer, and reboot the latter.
#79079 by jdthird
Mon Apr 11, 2011 6:15 pm
Also, do a VoIP quality test: http://www.whichvoip.com/voip/speed_test/ppspeed.html

Note: check the "Advanced" tab

>All were green, no packet loss, jitter 0.6ms, MOS 4.1, download 6.88Mbps, upload 730k.
>QOS is 82%.



If you have a cable modem, check some readings:

[quote="murphy"]Connect to the status web page in your cable modem
http://192.168.100.1

>downstream -1
>SNR 38
>upstream power 36

If your internet seems to be okay, make sure to setup your Ooma using Optimum Installation Settings:
viewtopic.php?t=9536#p66155

>Had already done this, set it 15% less than my average upstream.

No matter where your Ooma is placed, if setup.ooma.com "Quality of Service" section has and entry "Reserved Bandwidth for Calls (Kbps):" set it to 215 instead of the default 130.

>This was at the default, changed to 215

Still no joy, but thanks. Never bothered checking the cable modem status page like that, have to remember that. :)
#98376 by JumpingJackFlash
Mon Jul 30, 2012 2:25 am
I'm getting all green on the tests, but "jitter: you-> to server is 6.7ms compared to jitter:server->to you which is 0.6ms

I rarely had quality issues with Vonage.

Should I sub out the cable modem?
#98422 by vandergraff
Mon Jul 30, 2012 10:43 pm
This is a new set up with Comcast 12 Mbps / 2 Mbps internet.

There is a crackle on the line during calls - doesn't sound like a network issue - more like the old crackle on old analog phones with a bad line.

It is there even with a single phone directly plugged directly into the phone outlet on the helo.

I run the suggest network check - see attached.

Any ideas

EDIT - more detail on the test results

Upstream jitter 1.3 ms
Downstream jitter 0.8 ms
Upstream packet loss 0.0 %
Downstream packet loss 0.0 %
Upstream packet order 100.0 %
Downstream packet order 100.0 %
Packet discards 0.0 %
MOS 4.1
REGISTER ms 857 ms
INVITE ms 646 ms
BYE ms 9 ms
Test VoIP and Speed Test
Attachments
advanced summary.jpg
advanced summary.jpg (40.9 KiB) Viewed 45499 times
ooma connection summary.jpg
ooma connection summary.jpg (37.67 KiB) Viewed 45501 times
#98423 by lbmofo
Mon Jul 30, 2012 11:20 pm
JumpingJackFlash wrote:I'm getting all green on the tests, but "jitter: you-> to server is 6.7ms compared to jitter:server->to you which is 0.6ms

I rarely had quality issues with Vonage.

Should I sub out the cable modem?

Jitter alone don't look too bad. It is something else like packet drop and packet loss. Have you checked out your modem? http://192.168.100.1/

lbmofo wrote:JumpingJackFlash, did you just downgrade your cable Internet to a lite version? Or did you have the same package before you ported? In either case, your Internet quality doesn't look too good. People say how cable company caps speed isn't good for VoIP. High tcp delay, high jitter, packet discards & loss etc. Take a look at your modem and see what it looks like: viewtopic.php?t=10023
Might be something going on with your line condition or bad modem.
Btw, with those up down speeds, disable the down by setting to 0 and set up QoS to 700.
#98424 by lbmofo
Mon Jul 30, 2012 11:21 pm
vandergraff, your numbers look very good. Did you always use the phone you are using? Have you tried a wired phone directly plugged into the Telo to elimate your phone being the problem?

Who is online

Users browsing this forum: Google [Bot] and 14 guests