Need extra help installing your Ooma Hub or Telo system? Let us know.
#2668 by dknyinva
Sat Feb 07, 2009 7:24 am
Hello,

I was wondering if anyone could help me setup ooma in the DMZ. I originally had it between my cable modem and router and it was working fine until I'm unable to connect to my internal web server from the Internet. ooma tech support suggested I put ooma in the DMZ and I wasn't sure on how to do that. Could someone help out a newbie on how to setup ooma in the DMZ?

Thanks in advance
#2670 by murphy
Sat Feb 07, 2009 7:49 am
Connect the ooma to the cable modem.
Connect the router to the ooma.
Change the DHCP table of available IP addresses in the ooma to exactly one address. ie. make the start and end IP address under DHCP Configuration the same (172.27.35.2).

Also set the DMZ address on the same ooma configuration page to this address (172.27.35.2).

This forces the ooma to always issue the same IP address to your router.
All incoming traffic that is not specifically addressed to the ooma hub will be passed through to the router.
#2671 by dknyinva
Sat Feb 07, 2009 8:00 am
Thanks so much for replying,

My router has three NICs. One is connected to the cable modem (for Internet connection), second is connected internally (LAN connection), and an unused NIC (could I plug this NIC into the ooma for DMZ configuration, then made the changes as you suggested?)

Thanks again
#2672 by murphy
Sat Feb 07, 2009 8:51 am
No.

Turn everything off (cable modem, ooma hub, and router).

Connect the cable modem to the Modem port on the ooma hub.
Connect the Home port on the ooma hub to the WAN/Internet port on the router.
Connect a computer to a LAN port on the router.
Turn on the cable modem and wait until it syncs up (cable light on solid).
Turn on the ooma hub and wait until the ooma tab is blue.
Turn on the router and wait for it to initialize.
Go to the computer and using internet explorer connect to
http://setup.ooma.com

Select the advanced page.
Make the changes indicated in the previous post.
Click the update button.
Turn off the ooma hub and the router.
Turn on the ooma hub and wait for the blue light.
Turn on the router.

You should now be able to connect to your router, if you have remote administration enabled, from the outside world.
In other words it should work as if the router was directly connected to the cable modem.
#2673 by dknyinva
Sat Feb 07, 2009 9:02 am
murphy wrote:No.

Turn everything off (cable modem, ooma hub, and router).

Connect the cable modem to the Modem port on the ooma hub.
Connect the Home port on the ooma hub to the WAN/Internet port on the router.
Connect a computer to a LAN port on the router.
Turn on the cable modem and wait until it syncs up (cable light on solid).
Turn on the ooma hub and wait until the ooma tab is blue.
Turn on the router and wait for it to initialize.
Go to the computer and using internet explorer connect to
http://setup.ooma.com

Select the advanced page.
Make the changes indicated in the previous post.
Click the update button.
Turn off the ooma hub and the router.
Turn on the ooma hub and wait for the blue light.
Turn on the router.

You should now be able to connect to your router, if you have remote administration enabled, from the outside world.
In other words it should work as if the router was directly connected to the cable modem.

If you read my original post, ooma works fine with this setup. The problem I'm having is I cannot access my internal web site because of ooma is apprarently using tcp port 443, which is the same as my internal secure web site. Ooma tech support suggested putting ooma in the DMZ on a separate interface (3rd NIC on my router) and I'm unable to get it to come up. I'm close though, the indicator on the ooma (button 1&2 are red) is telling me ooma hub is unable to register to the ooma network. Any other suggestion is greatly appreciated.

Thanks
#2676 by murphy
Sat Feb 07, 2009 10:15 am
I just changed the administration page of my router to use port 443 and it went through fine from an outside connection. Try the setup I gave you.

ooma does not listen to the internet for it's controls. It sets up a VPN tunnel from the hub to the ooma server. All of the ooma traffic goes through the tunnel.

Your initial test did not have the router in the ooma's DMZ zone. That is required for it to work.
#2682 by dknyinva
Sat Feb 07, 2009 12:02 pm
murphy wrote:I just changed the administration page of my router to use port 443 and it went through fine from an outside connection. Try the setup I gave you.

ooma does not listen to the internet for it's controls. It sets up a VPN tunnel from the hub to the ooma server. All of the ooma traffic goes through the tunnel.

Your initial test did not have the router in the ooma's DMZ zone. That is required for it to work.

My ooma is working again using my original setup and even with your setup above, I'm still unable to connect to my internal secure web server via port 443. Any other help you can provide is greatly appreciated.
Your initial test did not have the router in the ooma's DMZ zone.
Can you clarify on what you mean by this?
#2683 by murphy
Sat Feb 07, 2009 1:28 pm
Did you modify the ooma configuration to restrict the DHCP table to one IP address?
Did you put that address in the DMZ entry?
Do you have port 443 forwarded, in your router, to the computer on your LAN that supports the web page?
Do you have the firewall in that computer set to allow that connection?

I can connect to the administration web page in my router from outside.
I can connect to any PC on my LAN from the outside using pcAnywhere.
I can connect to any PC on my LAN from the outside using Remote Desktop?
I can turn on PCs on my LAN from the outside using Magic Packets.

If it's not working for you , you have missed one of the configuration steps.

Possibly I know too much about how this all works and am missing something that I am so used to that I am not even thinking about it.

When you make the connection attempt are you using the public IP address that your ISP gave to the ooma hub? Are you actually running this test from outside your house?

Connect to

http://whatismyip.com/

to verify that you are using the correct public IP address.
#2686 by dknyinva
Sat Feb 07, 2009 3:11 pm
Did you modify the ooma configuration to restrict the DHCP table to one IP address?
Yes, please see attached image below
Did you put that address in the DMZ entry?
Yes, please see attached image below
Do you have port 443 forwarded, in your router, to the computer on your LAN that supports the web page?
Yes, without introducing the ooma VoiP it works
Do you have the firewall in that computer set to allow that connection?
Yes, firewall rule is configure to pass traffic to internal IP via port 443
When you make the connection attempt are you using the public IP address that your ISP gave to the ooma hub? Are you actually running this test from outside your house?
Yes using my iPhone via EDGE network NOT WiFi. Again, it would work if ooma is NOT introduce in my network.

Thanks again and I appreciate all your help
#2691 by murphy
Sat Feb 07, 2009 5:45 pm
I'm stumped. Are you using http://www.dyndns.org or one of their competitors to give you a URL that always points to your public IP address? If you are and have the router programmed to do the updates, that won't work. You would have to disable the updates from the router and run their client on a PC on your LAN to do the updates. The public IP address will be different with the ooma first than it was with the router first.

Who is online

Users browsing this forum: No registered users and 5 guests