Need extra help installing your Ooma Hub or Telo system? Let us know.
#34989 by stocks22
Sat Nov 28, 2009 9:59 am
Customer support stinks, period, end of story.

I would not advise anyone to purchase an OOMA. OODDUD is more like it.

The advertising is false and misleading because I had NO Idea the 2nd handset would not work until such and such an upgrade date.

Called support and all they did was LIE and drop off line or tell me to reboot and they would call me back.

Ooma support is horrible and I am also reporting all of the false and misleading advertising to the media and the BBB.
#34992 by Groundhound
Sat Nov 28, 2009 10:10 am
stocks22 wrote:Customer support stinks, period, end of story.

I would not advise anyone to purchase an OOMA. OODDUD is more like it.

The advertising is false and misleading because I had NO Idea the 2nd handset would not work until such and such an upgrade date.

Called support and all they did was LIE and drop off line or tell me to reboot and they would call me back.

Ooma support is horrible and I am also reporting all of the false and misleading advertising to the media and the BBB.

For those who may be wondering what "such and such an upgrade date" is, the current statement by Ooma for multiple handset registration is:
IMPORTANT: The current Ooma Telo software release only supports one Ooma Telo Handset. We plan to release a software update to support more than one handset on or before December 4th. If you have more than one handset, please keep the others powered off for now. This notice will be removed after the software update is released.
#36996 by kittcarr
Sat Dec 12, 2009 4:22 pm
Ok after ordering in the new equipment and having some time to dedicate to setting this up. I am currently on hold with Ooma support for the second time today so far I have not talked to a live person. 2 times now and on hold for over 30 mins each time.

So anyways. They have ported two of my phone numbers one was supposed to go to each ooma account but the one doesnt show in either but rings on ooma2's box.

I got 2 HP ProCurve 2524 24 port Managed 10/100 Switch J4813A and they are working fine now. My ooma2 lets me go to my voice mail BUT...... EVERY NUMBER I TRY TO CALL EXCEPT MY OOMA # ON THE OOMA1 BOX.. I GET THE "NUMBER You have reached has been disconnected..

Yeah !! tech support answered.... They called the ooma number and left a msg :D !!! but then i got disconnected :cry:


So I am no further ahead and my husband says to throw it all out the window. We need our phone to work .. its our business phone!!!!
#40413 by stocks22
Wed Jan 06, 2010 7:08 am
I can't even get support. I get a fast busy. Signed up for Premier and I don't know why. Said I would get a free telo handset, but when? Where is it? Fast busy on support line. WTF? POS company.
#40455 by southsound
Wed Jan 06, 2010 10:57 am
stocks22 wrote:I can't even get support. I get a fast busy. Signed up for Premier and I don't know why. Said I would get a free telo handset, but when? Where is it? Fast busy on support line. WTF? POS company.

First off, I don't speak for ooma. I'm just a humble user like yourself. But I do have Premier and with your history of harrassment, breaking into threads with totally unrelated gripes and garbage, etc., I would have you on my blacklist. I understand that ooma runs their company on their product. Who knows why you can't get through?? :P

Of course, ooma is an upright business with a great corporate integrity and would never do what I suggested that I would do. Thinking about it is just something that made me smile. I hope they get your problem fixed soon.

Who is online

Users browsing this forum: No registered users and 9 guests