Customer Service was great!

Need extra help installing your Ooma Hub or Telo system? Let us know.
Post Reply
costanzo98031
Posts: 63
Joined: Sun Nov 15, 2009 12:01 am
Location: Kent, WA

Customer Service was great!

Post by costanzo98031 » Mon Nov 16, 2009 3:18 pm

I just want to comment on the customer service I recently had. I was very surprised - the service was excellent! My issue got resolved and the person who worked with me was polite and helpful.

To give some background on my issue:

I purchased a ooma telo over the weekend and had discovered a defect in the product. The hub appeared to have something rattling inside it. Maybe this was from shipping, who knows. I just didn't want to keep it if it was broken.

Before replacing my device, I called CS on Sunday and got a live person within minutes. I explained the problem and told them I wanted to take the device back to exchange it for a different one. I was advised they could help me with this issue when I got a replacement.

I needed CS's help because I wanted to keep my old number from the first device. When I called back on Sunday, I was able to speak with a real person within a few minutes. I find this is amazing! Normally, one would expect to sit in a call queue forever.

The person I spoke with opened a ticket and explained that could take up to 72 hours to resolve but they would try to take care of it quickly as possible

Come Monday morning, I received a call from their customer support department. They completed the ticket and wanted to verified everything was working. The person I spoke with on the phone, was polite and stayed on the call till it was completed. I also got an email showing what had been done to my account.

Thank you ooma for resolving my issue this morning.

Post Reply