Need extra help installing your Ooma Hub or Telo system? Let us know.
#25013 by leatherneck
Thu Oct 08, 2009 1:30 pm
My outgoing voice was very low when I put Ooma hub behind my router. A few days ago, Ooma support staff suggested me to place Ooma hub between modem and router. It does improve my outgoing service quality. But lately it is casuing a lot of DSL down times. I think there is something to do with the way Ooma want us to connect the devices.

After reading some postings, I think QoS setting my help. How do I set QoS on D-Link DIR-615 wireless router? Isn't it default setting?

Thanks,

Richard :cry:
#25073 by dralter
Thu Oct 08, 2009 6:20 pm
From the manual:

'Some applications require multiple connections, such as Internet gaming, video conferencing, Internet telephony and others. These applications have difficulties working through NAT (Network Address Translation). Special Applications makes some of these applications work with the DIR-615. If you need to run applications that require multiple connections, specify the port normally associated with an application in the “Trigger Port” field, select the protocol type as TCP or UDP, then enter the firewall (public) ports associated with the trigger port to open them for inbound traffic.
The DIR-615 provides some predefined applications in the table on the bottom of the web page. Select the application you want to use and enable it.

Name:
Trigger: Firewall:
Traffic Type: Schedule:
1. Name: Enter a name (OOMA) for the rule. You may select a pre-defined application from the drop-down menu and click <<.
2. Trigger: This is the port used to trigger the application. It can be either a single port or a range of ports.
This is the port number on the Internet side that will be used to access the application. You may define a single port or a range of ports. You can use a comma to add multiple ports or port ranges.

Service Ports
ooma uses the following application ports for outbound data and voice traffic:
UDP 53, UDP 123, UDP 514, UDP 1194,UDP 3386, UDP 3480, UDP 10000-20000, TCP 53 and TCP 443.

3. Traffic Type: Select the protocol of the firewall port (TCP, UDP, or Both).

4. Schedule: The schedule of time when the Application Rule will be enabled. The schedule may be set to Always, which will allow the particular service to always be enabled. You can create your own times in the Tools > Schedules section.

No need to set the QoS in the ooma (change to 0 to disable) since you want to connect your pc to the router not to the HOME port of the ooma.
#25074 by dralter
Thu Oct 08, 2009 6:21 pm
Oh, and to access the configuration utility, open a web-browser such as Internet Explorer and enter the IP address of the router (192.168.0.1).
#25078 by ggilman
Thu Oct 08, 2009 6:26 pm
QoS on the router won't do anything unless you move the hub behind your router, but it sounds like you are leaning towards this. My DIR-655 does attempt to do some automatic quality adjustments but really not good enough. You'll want to set it up yourself.

There are a couple of steps. Feel free to ask questions if you don't understand any point along the way.

1. Assuming you are using DHCP, you need to set a client reservation for your ooma device. This will ensure that the hub always gets the same IP address. This is required because you then configure QoS by this address. On My DIR-655, this is under Setup->Network Settings->DHCP Reservations List.

2. You need to measure your uplink bandwidth. http://www.speedtest.net/ is a reliable source. You are looking for the upload speed. Your speed varies over time so ideally, you'd like to measure at a couple of different times to get a real idea of what your speed is.

3. Set up your QoS. On my 655, it is under Advanced->QoS Engine. Ensure "enable traffic shaping" is on. Uncheck "Automatic uplink speed" and instead plug in a number under "Manual Uplink speed". This number is based off of what you got in step #2. A general rule of thumb is about 80% of the number you got in that step. Make sure "Enable QoS Engine" is checked.

4. Set up a QoS rule. Below the other settings, you'll see where to do this. Give it a name (all assuming my 655 here, yours should be similiar). I'd set my priority to 30 but anything from 30-100 would work equally as well in most cases. For local address, set the one you reserved in step 1 above, for both entries. For remote address, use 0.0.0.0 to 255.255.255.255. Both local and remote ports from 0 to 65535 and protocols to "Both".

5. Reboot your router and that's it.

Effectively the settings in step 4 are a bit broad and could be refined a bit but it really won't matter in most cases & I provided the simplest settings.

If you still have issues after, your only recourse is to adjust the number you set in step 3 a bit lower.
#25082 by ggilman
Thu Oct 08, 2009 6:37 pm
dralter wrote:Name:
Trigger: Firewall:
Traffic Type: Schedule:
1. Name: Enter a name (OOMA) for the rule. You may select a pre-defined application from the drop-down menu and click <<.
2. Trigger: This is the port used to trigger the application. It can be either a single port or a range of ports.
This is the port number on the Internet side that will be used to access the application. You may define a single port or a range of ports. You can use a comma to add multiple ports or port ranges.

Service Ports
ooma uses the following application ports for outbound data and voice traffic:
UDP 53, UDP 123, UDP 514, UDP 1194,UDP 3386, UDP 3480, UDP 10000-20000, TCP 53 and TCP 443.

3. Traffic Type: Select the protocol of the firewall port (TCP, UDP, or Both).

4. Schedule: The schedule of time when the Application Rule will be enabled. The schedule may be set to Always, which will allow the particular service to always be enabled. You can create your own times in the Tools > Schedules section.


It looks like you are opening the firewall but I don't see anywhere that you are configuring qos. I'm running both a Telo and a regular ooma hub behind my router currently and haven't had to touch firewall settings at all.

On another note, with all of the ports listed here, you can see why I just opted to make broad settings for QoS in the setup I suggested. It's far easier that route than setting up as many as 9 QoS rules for the one device.
#25091 by leatherneck
Thu Oct 08, 2009 7:14 pm
I have trouble getting into 192.168.0.1, perhaps because I am using wireless connection only. My LAN (connection with cable) is not working at this time. I will ask my friend (a network admininstrator who is away for 2 weeks) to help me trouble shoot this problem. For now, I can live with less than perfect Ooma voice quality. I will tackle this problem in a couple weeks. Thank you all for your suggestions. I will print them out and try some of the solutions.
#25107 by ggilman
Thu Oct 08, 2009 8:36 pm
Did you set up your network or did your friend? Though 192.168.0.1 is the default, it is possible it was changed to something else. Assuming you're on a PC, open a command prompt and type in "ipconfig /all". You'll see a set of numbers. Look for one that says either "Router" or "Default Gateway". This should be the ip address you need to go to for configuration changes to your router. Just type this ip address into your web browser.

It shouldn't matter if you are doing this wired or wirelessly; you should be able to get to your settings either way.
#25145 by leatherneck
Fri Oct 09, 2009 6:44 am
I called ATT DSL Support to set up my wireless rounter. I did find out the address is: 192.168.1.1 by ipconfig/all. Thanks. I will work on it after work.
#25558 by leatherneck
Sun Oct 11, 2009 9:49 am
I was able to config DHCP setting to reserve one IP address for my Ooma hub. I also went to QoS Engine and did not find "enable traffic shaping" option, perhaps because of my firmware verison and model DIR-615. However, I saw QoS was already enabled. I unchecked "Automatic uplink speed" and change it to manual, 80% of test speed. I used http://www.speakeasy.net/speedtest. I did not mess with QoS rule. After robooting, my system seems to work fine, i.e., voice quality is good and no more DSL downtime. FYI, I connect Ooma hub behind my router (F/W version: 2.55).

Thanks everyone for your help.

R
#25764 by denny
Mon Oct 12, 2009 3:30 pm
By "connect Ooma hub behind my router," do you mean wirelessly? I'd like to connect my hub wirelessly, but haven't figured out a way to do it. I've tried putting putting a wireless adapter in the hub's USB port, but (not surprsingly) it does not know what it is. Right now the bug works fine connected via a cable behind my router, which is a Linksys WRT610N. This wireless router also has QOS. Any ideas on how to wirelessly connect the hub?

Thanks!

Who is online

Users browsing this forum: Google [Bot] and 8 guests