Need extra help installing your Ooma Hub or Telo system? Let us know.
#19759 by jschmidt
Thu Sep 10, 2009 7:28 pm
Hi. My requirements aren't too unusual I think. (1) I want to insure the best quality phone service first, and I want other web traffic second. (2) I want to do port forwarding so I can get to some devices in my home (for example, monitoring current solar power generation).

I have read many of the forums here and I think I'm doing what is recommended, but still no luck. I hope I'm just being an idiot and have set something wrong. Anyhow, this is what I've done so far.

The requirement for best quality phone service dictated the recommended configuration of

modem -> ooma -> router -> rest of home

This caused some problems with dyndns since ooma does not support dyndns, and if I use the router's dyndns i just advertise the private address it gets from ooma. I didn't want to run dyndns on a PC, because I don't have any PCs running 24/7. Finally, I got a dyndns client running on a linux-based NAS appliance which is up 24/7. dyndns now seems to be working well.

Now the problem is I can't get port forwarding to work no matter what I try. My basic strategy is simple:

ooma uses PPPoE to talk to modem and gets a dynamic address from the modem. In ooma advanced settings, I restrict the DHCP address it can give out to 172.27.35.10 only and I configure the DMZ to the same address so all ports will be forwarded to my router. Just for fun, I forward some ports explicitly using port forwarding.

Next I verified netgear router gets 172.27.35.10 as its dynamically assigned address. I also double-checked the ports were forwarded on the netgear.

I checked that dyndns returns the same ip address as ooma shows in its "ports" setup page for the modem inet addr.

Unfortunately, when I try to go to any of the three forwarded ports, I get no connection. I double-checked browsing to each of the addresses and ports locally, and I know this was working before I stuck in the ooma. I also tested from a separate internet connection outside the home, so i'm not suffering because my router or ooma doesn't do loopback.

I'm just about out of ideas now. The only thing I can think of is giving up and just sticking the ooma inside the network and buying a new router that has some QOS features. However, if I do this, will I get the same quality that putting ooma between modem and router will give me? Can anybody recommend a good-quality low-cost non-wifi router with QOS? How about getting rid of the router and just using ooma as my router? That doesn't seem to be recommended or commonly done, but I don't know why it wouldn't work. Perhaps concerned about possible ability for somebody to hack the ooma and bypass NAT and therefore get into the home network?

I greatly appreciate any help anybody can give me and thank you in advance. If we can get this problem solved, I think i'll be very happy with the ooma.

ooma network settings:
Image

ooma advanced settings
Image

ooma ports
Image

netgear status
Image

netgear port forward
Image
#19776 by t4feb
Fri Sep 11, 2009 2:16 am
Are you running a server? if so I believe your setup is (modem -> ooma -> router -> rest of home) It should be (Modem/Router/ooma) That way ooma is assigned its own address from the router. I hope I am understanding your question and if so try it this way.
#19781 by MakoCSH
Fri Sep 11, 2009 2:40 am
Where is your NAS currently?

ooma should be fine as your router. I've never heard of one being hacked. ooma should also be fine in your network. You may not need QoS depending on your bandwidth and usage. Check out http://tinyurl.com/nqt85s for tips on putting ooma behind your router. I would try it behind your current router first.
#19790 by tommies
Fri Sep 11, 2009 3:52 am
jschmidt wrote:Hi. My requirements aren't too unusual I think. (1) I want to insure the best quality phone service first, and I want other web traffic second. (2) I want to do port forwarding so I can get to some devices in my home (for example, monitoring current solar power generation).

The requirement for best quality phone service dictated the recommended configuration of

modem -> ooma -> router -> rest of home

Now the problem is I can't get port forwarding to work no matter what I try. My basic strategy is simple:

ooma uses PPPoE to talk to modem and gets a dynamic address from the modem. In ooma advanced settings, I restrict the DHCP address it can give out to 172.27.35.10 only and I configure the DMZ to the same address so all ports will be forwarded to my router. Just for fun, I forward some ports explicitly using port forwarding.

Unfortunately, when I try to go to any of the three forwarded ports, I get no connection. I double-checked browsing to each of the addresses and ports locally, and I know this was working before I stuck in the ooma. I also tested from a separate internet connection outside the home, so i'm not suffering because my router or ooma doesn't do loopback.


It's known that ooma hub does not support 'loopback', so your're aware of this already.

Your set up is working before ooma, and I believe it should work with ooma. I would try both DMZ or port forwarding as the only option with ooma(ie only DMZ and then only port forward but not both as you do now) to see if it helps.

Please post back your result and we go from there.
#19824 by jschmidt
Fri Sep 11, 2009 7:15 am
I just rechecked having only DMZ or only port forward, but not both. Still no luck. Although I should say, I couldn't figure out the best way to disable DMZ; setting 0.0.0.0 reset things back to the previous address of 172.27.35.10, so i just set 172.27.35.20.

I can't use the ooma behind the router because my router doesn't hvae QOS and I do notice the difference in call quality when doing heavy internet traffic from my PC.

Thanks for all the suggestions. I am still optimistic someone will come up with the magic trick to do to make it all work.
#19835 by MakoCSH
Fri Sep 11, 2009 8:28 am
jschmidt wrote:I just rechecked having only DMZ or only port forward, but not both. Still no luck. Although I should say, I couldn't figure out the best way to disable DMZ; setting 0.0.0.0 reset things back to the previous address of 172.27.35.10, so i just set 172.27.35.20


To disable DMZ clear the fields completely (i.e. leave them blank).
#19954 by jschmidt
Fri Sep 11, 2009 6:07 pm
Ok I cleared the DMZ (this time for real) and added a single port forward and still no luck. Starting to be less optimistic.
#19957 by scottlindner
Fri Sep 11, 2009 6:50 pm
jschmidt wrote:Ok I cleared the DMZ (this time for real) and added a single port forward and still no luck. Starting to be less optimistic.


How are you testing it to know it isn't working?

Scott
#19958 by tommies
Fri Sep 11, 2009 6:54 pm
On the Port status page of my hub, the number of txqueuelen for both HOME and MODEM are 1000. On your, it's 1000 on the HOME and only 3 on the MODEM. I don't know this has anything to do with your problem.

What is your hub Rev number in Status page?
mine is
Device Status - Rev: 27712.27712

I would try a hard reset, ie reset to factory defaul. After this you need to change the hub setting again: build in MAC in Network page, port forwarding in Advanced page.
To do this, unplug the hub for 5 minutes, hold down the blue/red ooma tab (yes it is a switch). Plug ooma power back in while holding down the ooma tab and continue to hold it down for about 30 seconds. This should reset ooma to factory default.


On your other question, if you do not need wifi, any low cost switch will work and let go of the router. However, the hub does not offer static ip, so it might present another problem of guessing the correct ip of your devices.

Who is online

Users browsing this forum: No registered users and 6 guests