Ooma, Port Fowarding, and DD-WRT

Need extra help installing your Ooma Hub or Telo system? Let us know.
Post Reply
Akari
Posts: 3
Joined: Tue Apr 28, 2009 10:28 pm

Ooma, Port Fowarding, and DD-WRT

Post by Akari » Tue Apr 28, 2009 10:43 pm

I'm currently using a new Ooma install, but port forwarding died and I'm having trouble getting it working. My connection is Wall -> Ooma -> Linksys router with DD-WRT firmware -> Switch -> computers.

The Ooma's IP is the default of 172.27.35.1. I set the router to DHCP forwarder instead of server, with a dhcp server of 172.27.35.1 (this is the part I'm really unsure about, I think it's important). After refreshing, the router picked up a WAN IP of 172.27.35.43, which I changed via static IP to 172.27.35.2 (and gateway is 172.27.35.1) just because. The problem is, my computer, after ipconfig release/renew, is still picking up a 192.168.1.xxx IP, and I have no idea why. I tried changing the PC's gateway to 172.27.35.1 just to see what happened (the PC is normally set with DHCP, so it gets gateway/IP automatically), and it killed my connection, so that's not it.

Obviously, I can't port forward with that, because Ooma won't forward to an IP that's not in its dhcp range. Please help. I'm still not 100% familiar with DD-WRT, so that's not really on my side.

Edit: Hmm, maybe if I force the Ooma to have a 192.168.1.1 IP, and maybe force the router to 192.168.1.2?

runagun
Posts: 31
Joined: Sat Mar 07, 2009 1:23 am

Re: Ooma, Port Fowarding, and DD-WRT

Post by runagun » Tue Apr 28, 2009 11:16 pm

My suggestion is to put Ooma AFTER the router and then put Ooma's addy in the DMZ of the router. Thats how I have it.

WayneDsr
Posts: 3790
Joined: Wed Feb 04, 2009 6:28 pm
Location: Northern Indiana

Re: Ooma, Port Fowarding, and DD-WRT

Post by WayneDsr » Wed Apr 29, 2009 7:27 am

I have to agree with RUNAGUN. You are using DD-WRT with a Linksys and the QOS controlls available have to be better than the ooma hub. I use a Linksys with Tomato firmware and the QOS contol is awesome. That would also take care of your port forwarding.

Wayne

Akari
Posts: 3
Joined: Tue Apr 28, 2009 10:28 pm

Re: Ooma, Port Fowarding, and DD-WRT

Post by Akari » Wed Apr 29, 2009 9:18 am

Hmm. We tried Wall -> Modem -> Router -> Ooma -> Switch, but everything stopped working. How would I do that? Change the router to DHCP server and give it back the 192.168.1.1 IP, then set the Ooma to DHCP (but then how would I connect to it, wouldn't it lose the 172.27.35.1 IP?)... something like that?

Edit: Ok, I've rethought this. If I do Wall -> Modem -> Router -> Ooma +Switch+computers, then the computers don't go through Ooma, and port forwarding stops working because the Ooma is DMZ-ed. Also, I can't do Router -> Ooma -> Switch -> all computers because I lack the ethernet ports to do so (we have 7-8 computers at home).

Considering that I don't really use QoS, and am willing to sacrifice it because our connection sometimes gets slow to the point where putting Ooma AFTER the router may lead to choppy call quality, what can I do to actually port forward with the Wall -> Modem -> Ooma -> Router setup?

niknak
Posts: 885
Joined: Tue Jan 27, 2009 7:53 pm
Location: Staten Island, NY

Re: Ooma, Port Fowarding, and DD-WRT

Post by niknak » Wed Apr 29, 2009 5:20 pm

....Also, I can't do Router -> Ooma -> Switch -> all computers because I lack the ethernet ports to do so (we have 7-8 computers at home...)
You can always get another switch and "daisy-chain" (uplink) them together for more ports

Akari
Posts: 3
Joined: Tue Apr 28, 2009 10:28 pm

Re: Ooma, Port Fowarding, and DD-WRT

Post by Akari » Wed Apr 29, 2009 11:23 pm

After attempting to force the Ooma into a 192.168.1.xx IP, I ended up with phone but no internet and effectively overloaded my router to the point where I had to hard reset it back to manufacturer's defaults before I could even connect to it. So, that wasn't going to work.

I gave up and am now doing Wall -> Modem -> Router -> Ooma + a couple PCs + switch to more PCs, and set the router to give more bandwidth priority to the Ooma. I suppose that's the safest way to do it, but it goes against how the Ooma was designed to work...

WayneDsr
Posts: 3790
Joined: Wed Feb 04, 2009 6:28 pm
Location: Northern Indiana

Re: Ooma, Port Fowarding, and DD-WRT

Post by WayneDsr » Thu Apr 30, 2009 8:10 am

ooma suggests going -->modem-->ooma-->router
but some of us find -->modem-->router-->ooma, pc's
the best way to do it. Your ooma will work just fine like this.


Wayne

bryanlyle
Posts: 361
Joined: Mon Mar 30, 2009 4:11 pm

Re: Ooma, Port Fowarding, and DD-WRT

Post by bryanlyle » Sun May 03, 2009 5:24 pm

WayneDsr wrote:I have to agree with RUNAGUN. You are using DD-WRT with a Linksys and the QOS controlls available have to be better than the ooma hub. I use a Linksys with Tomato firmware and the QOS contol is awesome. That would also take care of your port forwarding.

Wayne
Wayne, any change you could post our QOS settings for the tomato newbees?

thanks.
follow me on twitter: @bryanlyle

WayneDsr
Posts: 3790
Joined: Wed Feb 04, 2009 6:28 pm
Location: Northern Indiana

Re: Ooma, Port Fowarding, and DD-WRT

Post by WayneDsr » Sun May 03, 2009 6:11 pm

What I did was to make ooma's ip a static ip. (Under Basic / Static DHCP). Then in QOS / Classification I set each port ooma uses along with ooma's static Ip to give each outgoing port priority by labeling it in the HIGHEST catagory.

In Basic QOS I set my bandwidth to my highest upload speed 80-100%

When I receive a call ooma takes priority on the upload bandwidth.
If you watch your realtime bandwidth, you'll see ooma uses about 48k upload speed. Not much.

Not sure if I really needed all this, but ooma work perfectly with this setup.

ports:
udp 1194
udp 3480
udp 514
udp 49000-50000
tcp 443

Let me know if you need more info.

Wayne
Attachments
oomaportsetting2.jpg
oomaportsetting2.jpg (9.27 KiB) Viewed 17948 times
oomaportsetting.jpg
oomaportsetting.jpg (9.17 KiB) Viewed 17945 times

bryanlyle
Posts: 361
Joined: Mon Mar 30, 2009 4:11 pm

Re: Ooma, Port Fowarding, and DD-WRT

Post by bryanlyle » Mon May 04, 2009 2:15 am

Thanks Wayne!
follow me on twitter: @bryanlyle

Post Reply