Need extra help installing your Ooma Hub or Telo system? Let us know.
#97059 by rocksockdoc
Wed Jun 20, 2012 4:03 pm
I'm brand new to Ooma and it's still not working right after five hours of setup with tier1, tier2, and tier3 support.

My configuration is as follows (--> means wireless, ==> means wired):
WISP AP --> My Rooftop Antenna & Radio ==> Linksys WRT54G Router --> Ooma Telo ==> Telephone

One question that I have for the forums, is why on earth the Ooma help pages say to use 'either' http://172.27.35.1 or http://setup.ooma.com to get to the ooma configuration page?

How could setup.ooma.com possibly DNS out to 172.27.35.1?
It's not in the /etc/hosts file.
I'm using the Google DNS servers (e.g., 8.8.8.8) so they wouldn't have it either.

Why on earth does Ooma Support say to use http://setup.ooma.com when that can't possibly DNS out to 172.27.35.1?

What (fundamental concept) am I missing?

Here's what I do:
1. On linux, I use the wlan0 wireless adapter for my Internet
2. So, I plug the Ooma Telo into the eth0 wired port on my laptop
3. The other end goes to the Oooma Telo "Home Network" port
4. On Linux, I change the eth0 to the same subnet as the Ooma Telo (sudo ifconfig eth0 172.27.35.10)
5. Then, in Firefox, I visit the Ooma web page (http://setup.ooma.com)
6. This always fails (see the attached screenshot)
7. Then, in Firefox, I visit the same Ooma web page using http://172.27.35.1
8. This works fine (see screenshots below).

My question:
Q: Why does Ooma Support say to use http://172.27.35.1 or http://setup.ooma.com when there's no chance in a million years of http://setup.ooma.com actually resolving to 172.27.35.1?

I must be missing something fundamental here ...
Attachments
ooma2.png
There is no way setup.ooma.com is going to resolve to 172.27.35.1 ... so why does Support say to use that URL?
ooma2.png (52.07 KiB) Viewed 8683 times
ooma_1.png
Of course, 172.27.35.1 does resolve to the Ooma ... so only that URL can possibly work.
ooma_1.png (101.81 KiB) Viewed 8683 times
Last edited by rocksockdoc on Wed Jun 20, 2012 4:07 pm, edited 1 time in total.
#97060 by rocksockdoc
Wed Jun 20, 2012 4:06 pm
BTW, I added 'this' line to my /etc/hosts file on Linux, and only then would "setup.ooma.com" resolve to 172.27.35.1.
But my question is HOW could Ooma Support possibly expect setup.ooma.com to resolve to 172.27.35.1 WITHOUT adding this line to the /etc/hosts file?

$ sudo vi /etc/hosts
172.27.35.1 setup.ooma.com
#97061 by murphy
Wed Jun 20, 2012 4:08 pm
You are using a DNS service that tries to help you out by fixing your mistakes.
http://setup.ooma.com depends on there being a no find on the DNS lookup.
Ooma catches that and displays the internal web page.
The first I heard of this was from people using OpenDNS.
They always return a hit no matter what you type.
#97069 by rocksockdoc
Wed Jun 20, 2012 8:42 pm
murphy wrote:Ooma catches that and displays the internal web page. They always return a hit no matter what you type.


Hmmm... OK. I guess. This is a 'special' usage of DNS, I guess.

What you're saying is that, when the computer is wired directly to the Ooma, and when I go to 'setup.ooma.com', the Ooma has its own DNS server (somehow) which returns the web page at http://172.27.35.1/home.lp

I just tried it on a computer that did NOT have 172.27.35.1 in the hosts file (it was a WinXP machine so the hosts file is C:\windows\system32\drivers\etc\hosts).

Here's what happened:
a) I connected the router "To Internet" port to a router output port with a CAT5 ethernet cable;
b) I disconnected the WinXP computer from a router output port & then connected it to the Ooma "Home Network" port;
c) I opened up Firefox on WinXP and opened up three tabs'
d) In the 1st tab, I typed "http://foo.ooma.com" ... This said "Server not found";
e) In the 2nd tab, I typed "http://setup.ooma.com" ... This said "Server not found";
f) In the 3rd tab, I typed "http://172.27.35.1" ... This brought up the Ooma home.lp page;
g) Interestingly, I reloaded the two tabs that didn't work prior;
h) Guess what? The "setup.ooma.com" tab now worked!

Go figure!

So, this 'proves' (sort of) that 'setup.ooma.com' resolves to 172.27.35.1 (at least after I already went to 172.27.35.1); but it also shows that anything other than setup.ooma.com does not resolve to 172.27.35.1 (at least in my tests).

I consider this interesting ... but for me, I'll just go to http://172.27.35.1 and not worry about the inconsistent results using the easier-to-remember "setup.ooma.com" URL.

Who is online

Users browsing this forum: No registered users and 9 guests